1GHz still not working in v3.1.0-rc9?

I just tried the image from http://rcn-ee.net/deb/natty/v3.1.0-rc9-d4
and found that 1GHz still not working on my BeagleBoard xM - B.
I still get the following error - "clock: dpll1_ck: unable to set MPU
rate to 1000000: -22".

I thought that such made it into 3.1 upstream?

Best regards
- Jim Ronald

Hi Jim,

There's still a couple external patches floating around to achieve
that, so it's not completely mainline yet... It might just work now
to enable the 1ghz option in the board file, but i haven't tested it
since 3.1-rc1-2 (it was still locking shortly after boot)...

Regards,

Robert,

Thanks for the feedback and the great resource. I assume that this is
also an issue for the PandaBoard? Are you building just from upstream
sources? Besides Angstrom, are you aware of any other such projects
that pull in the interesting BeagleBoard xM/PandaBoard patches?

No the PandaBoard is running fine at 1Ghz.. If your's isn't and is
running at 600Mhz, you have an old X-Loader..

That rc9 tree is pretty close to upstream..

It's really just: cpufreq from kevin that's heading to 3.2, a couple
igepv2 fixes, support for the expansion boards and few other odd
tweaks.. (besides the big sgx patch for omap3)

https://github.com/RobertCNelson/linux-dev/blob/master/patch.sh

Ubuntu/Linaro is really the only other tree for PandaBoard, they have
a pretty massive patchset for it.. But otherwise mainline on the panda
has been pretty nice so far.. (minus the omap4 sgx, dsp)

Regards,