4.1.21 pause during boot: A start job is running for LSB: Raise network interf...

Why does the kernel pause for a will (10s) while booting. I see the pause in line noted in red below. Something to to with phy 4a101000?

r 10.287710] net eth0: initializing cpsw version 1.12 (0)
[ 10.295460] net eth0: phy found : id is : 0x7c0f1
[ 10.300245] libphy: PHY 4a101000.mdio:01 not found
[ 10.305086] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 10.315002] net eth0: BQL enabled
[ 10.322353] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[****] A start job is running for LSB: Raise network interf…31s / limit)[ 37.822466] random: nonblocking pool is initialized

If there's no Ethernet connected, it will pause there for a long time. I think it's looking for DHCP. It's possible to configure this to skip this at boot and support hot-plug, but the distro is (IMHO unfortunately) not configured this way.

Bump.

Anybody found a good fix for this? I am now in 4.4 land and it seams to hang even longer… Quite annoying. I don’t use eth0 as my devices talk over a cellular network…

make sure eth0 is not defined in /etc/network/interfaces

Regards,

Did that. All lines in /etc/network/interfaces are commented out. Still getting the LSB

Here is a screenshot:

Is it because the it because it find the eth0 phy but and is trying to give a IPv6?

You can disable ipv6 at the kernel level.

william@beaglebone:~$ cat /boot/uEnv.txt | grep ipv6
#cmdline=coherent_pool=1M quiet cape_universal=enable ipv6.disable=1
cmdline=ipv6.disable=1