40W and NAND seems... Flakey and OTG issues

Hello!
I have my Beagle all setup...
Well, was all setup.

I had Angstrom on NAND (thank you koen!) and Angstrom on SD.

Plugged in after 2 weeks of working fine, when orange screen, went
black - Nothing booted.
Then after that (I ran it via OTG port) the only light I had was pwr.
So dead. Yes. I done a recovery hit using beagle_recovery scripts
(worked great!).

So after that I ALWAYS have 40W on each boot that I put in an SD card
and the NAND does not seem stable anymore.
I installed Angstrom to nand and got xloader-1.44ss on it.
Formatted an SD as required with Angstrom and its working ok, yet I am
still getting 40W each time I try boot from SD even tho it is working.
I thought 40W was an error?
Also, Ubuntu - When I use the script to format and install 10.10 it
goes well, I place it into the beagle and under serial connection says
something is updated, remove SD and reboot, when I did, it would not
boot past PWR again and NAND was seemingly blank? I had to do a
recovery again..
What could be causing this?

I also had an issue of when I plugged in an OTG plug it instantly went
to kernel panic. Would not boot if powered by the same OTG plug that
was used for weeks. Not on mains, it was KP'ing when otg was in.

I replaced the kernel from koen's nand angstrom with the newer kernel
from recent demo of ang and this seemed to fix the problem on otg
plugged in.