4D 4.3" LCD not working in Debian 8.3?

Hi all,

I have a Beaglebone Black with an 4D 4.3" LCD cape installed.

With Weezy the LCD cape worked, but with Jessie the LCD is gray blank? Am I doing something wrong or is the overlay broken?

The cape is seen, though:

debian@beaglebone:~$ cat /sys/devices/platform/bone_capemgr/slots
0: P—L- 0 4D 4.3 LCD CAPE- 4DCAPE-43T ,00A1,4D SYSTEMS ,BB-BONE-LCD4-01
1: PF---- -1
2: PF---- -1
3: PF---- -1

Any advice?

Thank you,
Errol

edit: /boot/uEnv.txt

dtb=am335x-boneblack-emmc-overlay.dtb

Regards,

I posted this back in September: it may or may not help you:

ok. I have SOLVED all of this.

I put this in the 4dsystems forum, and I repost it here.

The 4dsystems beaglebone cape with Ubuntu + LXDE is working just fine, and here is how I did it:

This is for ubuntu 14.04 and lxde, there is a utility named xinput_calibrator for x11

steps to make this work:

Note: I use the lxde window manager, so you might have to change this for your wm:

ssh into the beaglebone:

need to get a virtual keyboard up, and get past the login screen:

  1. as root, do an apt-get install xvkbd (so that you can run the terminal and use touchscreen for giving commands
  2. as root, edit /etc/lxdm/lxdm.conf:

uncomment and set autologin username to enable autologin

autologin=ubuntu (or whatever username you have made)

uncomment and set timeout to enable timeout autologin,

the value should >=5

timeout=5

  1. as the user (ubuntu, or other user edited as autologin= in the lxdm.conf file):

so in the $HOME/.config/lxsession/LXDE/autostart I added this: xvkbd -minimizable -no-keypad -geometry +150+150 &

the above gets the virtual xvkbd up on the screen (if not running with a keyboard, like me)

now: shutdown the bbb, and attach to the LCD cape, and boot up to the screen.
(1) the login screen should come up, wait for 5 seconds for the login to time out, then wait for lxde to start up
(2) you should see the screen come up with the virtual keyboard

now, start a terminal. hopefully it is an icon, if not, make it one and start again

once a terminal is up, focus to the terminal, then focus to the virtual keyboard

  1. sudo su -

now, as root do:

  1. apt-get install xinput-calibrator

  2. run xinput_calibrator and you will get something like the following:
    Section “InputClass”
    Identifier “calibration”
    MatchProduct “ti-tsc”
    Option “Calibration” “121 4028 303 3852”
    Option “SwapAxes” “0”
    EndSection

  3. edit the /etc/X11/xorg.conf file: and add that above section to it.

  4. shutdown and boot up again.

The screen should be calibrated correctly!

I hope this helps everyone. Whew!

I am ECSTATIC!

At time I have the same problem with a 4DCAPE-70T.
I have checked the answer of RobertCNelson without success…

Do you have found a solution?

Thx