A6A BBB - eMMC flashing issue?

Hey, fairly new to the BBB, decided I’m a bit overrun with rPi’s and it was time to change things up…

I wanted to get Debian on the BBB, went to http://elinux.org/BeagleBoardDebian#Debian_7_.28wheezy.29 downloaded the https://rcn-ee.net/deb/flasher/wheezy/BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img.xzm dd’d it to a 8GB micro card, put the card in and hold the boot switch down, plug in the BBB… and power light… nothing else.

I originally thought maybe I wasn’t holding the down the button long enough, so, I tried holding it down for three minutes (left a nice imprint on my finger) and still, just a power light. It boots fine without the SD card to Angstrom… just can’t get anything to work as far as flashing the eMMC

So far tried different SD cards, the Debian image I linked, an Ubuntu image, about to try Arch, but so far same result… just a power light, the BBB has been unboxed for all of an hour now and this being the first thing (which should be relatively easy) I’m trying to do and just nothing is working out, any help would be much appreciated.

Did you try the factory image to get a handle on the overall process?


The image works as designed...
md5sum BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img.xz

unxz BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img.xz

md5sum BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img
66f22a7bd7d50e38d60a0792ce3f1b0a BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img

sudo dd if=./BBB-eMMC-flasher-debian-7.3-2013-12-17-2gb.img of=/dev/mmcblk0
3481600+0 records in
3481600+0 records out
1782579200 bytes (1.8 GB) copied, 491.611 s, 3.6 MB/s

So... Please confirm that you followed the proper flashing procedure..

5 volt DC power supply (no USB otg cables for power!!!)
Nothing attached to BBB, ethernet cable and serial (5pin ftdi adapter)
are fine, but NOTHING else..

Make sure power is not applied.
Place microSD card into slot.
HOLD down boot button (and continue holding down)
Plug in power.
Wait till all 4 LED's are on, let go off boot button.
Flashing should take 7-13 minutes, all 4 LED's will be on when complete.
Remove power
Remove microSD
Boot your new flashed image.

If your procedure varied in anyway, retry...


Hi Robert,

I followed the procedure all the way till “Wait till all 4 LED’s are on”.
How long should the wait be? I would expect no more than 30 seconds… am I right?
Nothing happens, I keep waiting nothing…

Some info:

  • Beaglebone Black rev A6
  • I’m using an 8GB Sandisk microSD HC (I can confirm that BBB can see it from Angstrom if formatted FAT)
  • I use a Mac to dd the microSD

What am I doing wrong?


Hi Robert,

I followed the procedure all the way till "Wait till all 4 LED's are on".
How long should the wait be? I would expect no more than 30 seconds.... am I
Nothing happens, I keep waiting nothing...

"nothing".... the led's should light up one at a time before all 4
are lit up.. does it do that? All within 5-6 seconds of power up..
If it doesn't, then dd'ing the card failed.. How did you dd the card?

Some info:
- Beaglebone Black rev A6
- I'm using an 8GB Sandisk microSD HC (I can confirm that BBB can see it
from Angstrom if formatted FAT)
- I use a Mac to dd the microSD


Hi Robert,

thanks for the quick reply, you are fast!
The card was in the Macbook SD slot (through an adapter), I dd it from the OSX terminal using the command as you showed.
The terminal feedback was identical.

When I powerup while pressing boot only the power LED close to power connector turns on. None of the 4 USR LED does.
Any idea?

It sounds like the boot partition wasn't setup..

Since I don't have any Mac systems (really need to setup a cheap
hackintosh..) can you please confirm "exactly" how you dd'ed it just
encase you dumped it to a partition instead of the drive..

As I'm about to pull the trigger on a big announcement, it would be
nice if we knew the images could be dd'ed on mac..


Hi Robert,

oh, I did not know that the images are not proved to work if installed with a Mac.
The first time I tried to install another distro on the BBB (it was Ubuntu) I followed Adafruit instructions which are for a Mac and are basically the same.
See the link: http://learn.adafruit.com/beaglebone-black-installing-operating-systems/mac-os-x

Anyway I wrote:
sudo dd if=./BBB…img of=/dev/disk1s1

Seems correct to me.
Btw, is it normal that, after writing the image on the microSD, the card becomes not visible by the Mac? It complains saying it is not compatible or something and it does not get mounted at all.


s1, isn't that "partition 1"...???

They show:

sudo diskutil unmount /dev/disk4s1
sudo dd bs=1m if=~/Downloads/BBB-eMMC-flasher-2013.05.08.img of=/dev/rdisk4

with: /dev/disk4s1" changed to "/dev/rdisk4"

So you'd use.. of=/dev/rdisk1 right???


Hi Robert,

That makes sense… :wink:
For some reason I did not remember that and I haven’t looked at that guide since (in all other places nobody talk about that so i forgot)

I will try when I go back home and update the forum. Should work now. Many thanks!!

LEDs are flashing! Seems it works.
Thanks! I don’t know how I missed that instruction.