Accessing Cloud9 over intranet vs. access via USB ethernet?

Hello all! I’m a newbie; been playing with BBB for about a month. I’ve been doing Bonescript programming via the Cloud9 IDE. I work at a uni with an intranet; I found that I couldn’t access the BBB via USB ethernet ( is not found) unless I disconnected my PC from the work intranet. I didn’t want to keep disabling/enabling my internet connection for BBB development/checking email, so I set up a separate, offline development PC, which I used to do my BBB dev via USB ethernet.

Eventually I tried connecting the BBB to the uni intranet via its ethernet connector; it was assigned an IP address (currently I have been able to use this IP address connect to the BBB through the uni network via SSH and SFTP (Putty and WinSCP). I can also use this address to access the BBB web server. I was hoping that I’d be able to access the Cloud9 IDE by browsing to If I do so, I can view the various .js file that I have saved to the BBB, but I cannot open or run them - double-clicking on the filenames does nothing, and if I right-click on a filename, all the menu options are greyed out. I can run the Bonescript examples at (turn LEDs on, off, etc.); I just can’t open/access my scripts via Cloud9.

Any help would be gratefully received! It’d be good to be able to do all the dev on one PC via what I’ve described in the second paragraph. I am running Windows 7 64-bit (version 6.1.7601), and am accessing the BBB via Chrome version 28.0.1500.71 beta-m.

Many thanks,


Found a work-around: SSH into the board and run Bonescripts via ‘node <script.js>’. Might help someone who has the same problem. Still no insight into why it’s happening though.