AI-64 flash eMMC question (and 403 Forbidden)

Just received board. Am trying to flash the latest Bullseye XFCE image from here - latest-images


Is booting from this supposed to flash the image to the eMMC?

I write the image to an SD using etcher, plug in, and get the board to boot from the SD. There is some LED activity, and then for a few minutes a little march of the LEDs … is that the image being written to eMMC?

Eventually the marching stops and I see the following LEDs … is this correct? Does this indicate a successful write to the eMMC? Should | now be able to boot this image from the eMMC?


Ok, after multiple attempts with different SD cards it looks like this has eventually worked … I see


When I try the web interface on (or .6.2) I get this …


What’s going on there and how do I fix it?

I ran update/upgrade and now see


which is perhaps a step in the right direction? But still not correct. What is my next step?

NodeRed on port 1880 is working fine.

1 Like

nginx is really still in it’s default debian installed mode…

You will find VSCode running on port 3000…


Shall we add a reverse proxy for VSCode? Can you summarize here what the issue is with the service start-up on port access so that VSCode doesn’t have to run all the time?

We shall, just need to debug that…

VSCode doesn’t currently support socket activation in it’s current build. Due to the build infrastructure needed to ‘fork’ the project, it would best to post a patch mainline and wait till they build it in a monthly release.



Ah, Ok … was expecting to see a Beaglebone page. No prob.

Nope, it’s pretty much free for what ever you’d like to install on it!


Ok, thanks.

And thanks for the super help!