am335x-common-bone.dtsi file, I tried modifying it and porting to BBB

I modifed am335x-common-bone-dtsi file and I compile the u-boot and kernel, and port to BBB. Then i notice the BBB hasn’t implemented the changes, and then I look at the file on the host machince and I notice it had reverted back to it’s old self. Does anybody know why it would revert back to its old slef and how can I fix this problem?


Yes, of course I am idiot. The applies the patches right at the beggening and wipes out all my
changes. Therefore, what I can do is in the I can add a line to replace the patched up files
with my new files right after the patches were implemented. Ha Ha Ha!!!

or apply the patchset, then do your changes and create a new patch. Then mod the script to use your new patch with your changes included. Just another option.


Yes, I did this basically and was able to get uart 1 and uart 4 to work without having to use the cape manager. I will also need to get several gpios to enable also. But I haven’t tried
overlays yet. I basically added command in the to apply my new am335x-common-bone.dtsi file. I noticed that the uart was operating at 9600 buad instead of the 115.2k
as I need so I need to fix this, or use the software commands in the termios.h posix api. to set the baud.