Android-Froyo port for OMAP-L138 HawkBoard

Hi,

We are pleased to release the Android - Froyo port for OMAP-L138 HawkBoard.

The binaries & the build instructions for the Android Froyo port can be downloaded from :

http://coredruids.org/demos/Android_Froyo_Hawkboard_01-OCT-2010.tar.bz2

We will soon release the source code for the same.

We appreciate your joining our open source initiative, reviewing our work and sharing your knowledge & experiences with us.
Google groups : coredruids@googlegroups.com
Source code repositories : http://gitorious.org/~coredruids (Android Enablement)
Follow us on twitter : http://twitter.com/coredruids

Thanks
CoreDruids Team

Hi,

We are pleased to release the Android - Froyo port for OMAP-L138 HawkBoard.

The binaries & the build instructions for the Android Froyo port can be
downloaded from :

http://coredruids.org/demos/Android_Froyo_Hawkboard_01-OCT-2010.tar.bz2

We will soon release the source code for the same.

We appreciate your joining our open source initiative, reviewing our work
and sharing your knowledge & experiences with us.

Works perfect except for sound, I have an plication on Eclipse that
plays a song but I can not play it on hawkboard, the song is a .wav
file that i can play on hawkboard with aplay in other FS, Hope it
could be fixed or tell me if I am doing something wrong

Thanks

Sincerely yours

Victor Rodriguez

We are pleased to release the Android - Froyo port for OMAP-L138 HawkBoard.

Nice to see android release for hawkboard (more like beagle family) :slight_smile:
will be great if source is hosted on gitorious or github (like rowboat
- Google Code Archive - Long-term storage for Google Code Project Hosting. )

Works perfect except for sound, I have an plication on Eclipse that
plays a song but I can not play it on hawkboard, the song is a .wav
file that i can play on hawkboard with aplay in other FS, Hope it
could be fixed or tell me if I am doing something wrong

Android too has aplay by default (named alsa_aplay).
check if sound device is proper by "asla_aplay -l"

if you get alsa_aplay working with .wav, can you also test with
regular Froyo Music app??
(after all .wav is supported by android -
Supported media formats  |  Android Developers, and
works good with froyo music app )

u can also try cmd like "am start -n com.android.music/.StreamStarter
-d /sdcard/music.wav"