Android port for beagle(OMAP3530)- Code Released

Hi,
   We are releasing source code for Android port on beagle board. So far we have tested input device(keyboard/mouse), network(over USB) and sound (*.mp3).

A brief How to can be found here :-
http://labs.embinux.org/android-porting-on-beagle.html

You may also browse the kernel modifications at :-
http://labs.embinux.org/git

We will come up with more updates very soon..
Enjoy Androing.

Regards,

Hi All,

Please find below video showing Android on beagle board. It demonstrates navigation on Android, sample applications, and browser.

http://in.youtube.com/watch?v=nADn_vNVEKw

Regards,

This is really great effort and thanks a lot for releasing the sources.

Regards,
Khasim

Hi,

Thanks Rupesh.
we followed the sequence provided by you. In the first step of compiling the linux omap kernel,
its giving uImage build ready message but we are unable to get the uImage in arch/arm/boot folder.
we got zImage and Image.
Do we need to rename the zImage to uImage ?
if so u-boot will recognize the format ?

Thanks & Regards
Rao

Rao,
Is “$mkimage” command available on your development machine? If it is there, then you should get uImage in arch/arm/boot/
I dont think if you use “zImage” or “Image” will work with u-boot.

Regards,
padmarao edapalapati wrote:

Thank you for all your sweaty-efforts.
it will be much appreciated if you upload downloadable-image stuff
for newbi.

Make sure mkimage is in your path and then do this

make ARCH=arm CROSS_COMPILE=arm-none-linux-gnueabi- uImage

Regards,

mkimage is in the tools folder of the uboot git.

git clone git://www.sakoman.net/git/u-boot-omap3.git
cd u-boot-omap3
git checkout --track -b omap3-dev origin/omap3-dev

copied from

http://elinux.org/BeagleBoard#U-Boot

Hi all,
You can download binaries (kernel uImage and Android RFS) from following link:-
Regards, rainman747 wrote:

Thanks for u r help
i got the uImage

Regards
rao

Hi Rupesh,
Thanks for your help. I able to get the android command prompt as well as GUI.
But when i am trying to connect my USB otg to self powered hub(only keyboard connected to hub),
not getting power to keyboard.
how can i know whether OTG is working as host or not ?
Is there any code modification is necessary to make it as host ?

Thanks & Regards,
Rao

Rao,
With which USB connector you are connecting to beagle board. You need to connect with USB Mini-A connector to beagle board, for it to work as a host.

Regards,
padmarao edapalapati wrote:

Hi,Rupesh,

i don’t have USB Mini-A connector, so i connected USB-OTG 4thpin(id) with ground on the board and using Mini-B connector,but it didn’t work as host
what is wrong in my connection.

Regards
Rao

Hi Padmarao,

You have followed right steps. But could you please
verify using multimeter, is GND and pin4 is really shorted?
also make sure to select USB host mode while "make menuconfig".

Regards,
Shivdas Gujare

Thanks a lot! But I cannot compile alsa_sound, which reports a lot of
errors.

I had the same problem using the Android Cupcake branch. I just
didn't add the audio support, and it builds and runs mostly fine. The
only issues I'm seeing are the Soft Keyboard introduced in Cupcake
crashing (although it did come up on the screen one time.) Also,
since I'm using the dual-partition SD card for the uImage and Android
Filesystem, I cannot use the SD card for Android storage. I wanted to
try downloading some apps, but they require the SD card to be
available. I tried using a USB Memory Stick for the Android
filesystem, and it works; however, when using it in conjunction with
my USB Ethernet Adapter (AirLink 101) the simultaneous use of Ethernet
and USB Memory stick cause the kernel to crash. I saw a bug was filed
on this on the Issue Tracker:

http://code.google.com/p/beagleboard/issues/detail?id=31&can=1

Unfortunately, there is no root-cause found for it, and it looks like
there is no plan to fix this problem. Using a USB 1.1 hub as a
workaround is not a great solution since 1.1 hubs are difficult to
find these days, and slow down the performance.

I also tried using using MTD partitions to store the Android
Filesystem, but Android's "flash_image" utility fails, and directly
mounting the MTD partition and writing to it seems unstable (kernel
crashes frequently.) I will try the latest version of Angstrom and
see if the MTD partitions work there.

I tried the HDMI on my TV and it didn't work, but it does work well on
my both LCD computer monitors I tried.

It will be nice when the Rev C boards with working EHCI controller are
available. Then it will be possible to use the EHCI controller for
USB devices, and use the OTG port for USB Gadget and Android Debug
Bridge (ADB.)

The BeagleBoard will make a nice Android set-top box if some of these
issues can be resolved.

-Howard

Hi Howard,

Howard wrote:

I tried the HDMI on my TV and it didn't work, but it does work well on
my both LCD computer monitors I tried.

Take care - Even though the BeagleBoard uses a HDMI connector (for space
saving purposes), the output is really DVI-D and not HDMI... You can
therefore not expect it to work with your TV HDMI input...

Best regards
  Søren

It will, however, work with just about every HDTV if properly configured for that TV. The code used in most of the popular demos today does not utilize the proper pixel clock for standard 720P.

There is no audio connection, which is a reason it is not real HDMI.

Thanks for the info. At this point, I'm more concerned with reliable
USB and getting the MTD partitions working.

I'd also like to get the second UART and SD interface on the expansion
connector working. I have a 1.8v SD device, so it should just be a
matter of wiring it up, and software.

Has anyone used the SD interface on the expansion connector?

The BeagleBoard is really a neat little board.

-Howard

Hello:

Just put this on a BB- should I expect USB Ethernet to work? Or do I
have to build in support and build my own kernel? I'm using the pre-
build version that you have kindly supplied. I'm using a linksys USB
Ethernet dongle.

I read that Android doesn't know about USB, so how is working on the
BB ?

-andy