Android port for OMAP3 with GStreamer integration

Hi All

We are pleased to announce the release of Android build integrated with
GStreamer for OMAP3 platforms (BeagleBoard & OMAP3EVM). Current Embinux
kernel for this Android port is derived from linux-omap-2.6.29.
Source code can be found at
http://labs.embinux.org/git/

Current release of Android port for OMAP3 has following features/support
   * Support for BeagleBoard
   * Support for OMAP3EVM platform
   * Android Toolchain's replacement with Embinux Toolchain (GCC-4.4.0,
Binutils-2.19.1, Cortex-A8)
   * GStreamer (0.10) integration

The release notes, download and build instructions are available from
http://labs.embinux.org/index.php/Android_For_OMAP3_with_Gstreamer_Integration

Hi,

I can't able to open the following link, i think link is down
http://labs.embinux.org/index.php/Android_For_OMAP3_with_Gstreamer_Integration

Even I face the issue in opening the link
http://labs.embinux.org/index.php/Android_For_OMAP3_with_Gstreamer_In
Any Idea when would it be up?

Regards,
Sanjeev Kumar Verma

Ramananda,
There was a temporary problem with our servers, now it is up and running.

Regards,
rama wrote:

Hi Rupesh,
How do i build the kernel only in the android setup instead of the whole android system ?
I need this to add some features to kernel.

Thanks and regards,
Velu

Hi All,
I would like to ask whether this gstreamer on android platform for
OMAP3530 board would suport
a) playing of streaming H264 videos or
b) playing of SDP file
using RTP/RTSP protocol stack
Also please suggest me how should I proceed for doing the same on
android platform with any info possible
Thanks

Hi all,
For me display comes if I connect the LCD to the beagle board, but
does not come if I connect the Sony HDTV.
Does any body have the bootargs to connect the -
1.Sony HDTV
2.TV with S Video

Regards,
Sanjeev Kumar Verma

Sorry to drift from the topic. But Is it possible to use a usb wifi dongle and provide wifi support to omap3droid ?

Yes, It can be achieved.
Jorjin technologies had already achieved it for SDIO wifi.
Regards, vishal bhoj wrote:

Hi All,

Anyone know how to get the Dev Tools application running? It is not
showing up in the applications window.

Regards,
Steve

I am sorry that I have a basic Android question: my understanding is
that the primary development language for Android is Java. What I
would like to know is if there is a Python and/or C/C++ compiler as
part of the Android build for Beagleboard.

Also, can you list out what modules are enabled by default on the
expansion header on the Beagleboard for the binary Android build for
BB?

Thank you,
Tyler

The primary language for writing Android applications is Java,
although a Native Development Kit (NDK) is now available for Android
which allows you to write portions of your app in C/C++.

But underneath the UI, Android is based on Linux, so any language that
has a cross-compiler for ARM/Linux can be used. The trick is figuring
out how to communicate between native code and Android, and the NDK
makes this possible to a limited extent.

I don't think any of the peripherals on the expansion connector are
enabled by default. You will have to modify uboot and the kernel to
make these work.

-Howard

Rupesh,

Ive made the patches with credentials.
http://groups.google.com/group/beagleboard/web/armv7a-build.patch
http://groups.google.com/group/beagleboard/web/armv7a-dalvik.patch

I hope this is what you meant. Thanks.

McGeagh,
  Thank you McGeagh. Patches looks good. I will try out along with your
instructions.

Regards,

Hi all,

Is there any means to "install" .apks without an adb connection with
this build configuration? I am working with a B7 BB. I can create my
own debug keyed apps and install and run, but cannot install apps I
have not signed.

I have seen threads indicating adb on BB will come with the rev C
(because of a 2nd USB path?). Any suggestions?

Regards,
Steve

Hi Rupseh et all,

Is there any update on the music player crash issue ?

Is anyone investigating on the same ? We can share our thoughts for us to fix it faster.

To start with, I followed some of the steps mentioned in the below link, but no luck:

http://jfyi.blogspot.com/2009/06/android-music-app-on-beagle-board-1.html

Thanks and regards,
Velu

Hi All;
I am using gstreamer in Angstrom and I have problem with rtsp stream I
tried to catch rtsp stream to file sink it write something into file
but when I use
gst-launh rtspsrc://<IP>/mpeg4 ! rtpmp4vdepay ! ffdec_mpeg4 !
ximagesink
I din't see any video in screen I run it by debug level 5 and I think
ffdec_mpeg4 not working how can I fix it.

I'm trying to start Embinux Android on beagleboard Rev C2. I have made
everything accordingly with http://labs.embinux.org/index.php/Android_For_OMAP3_with_Gstreamer_Integration
and McGeagh instructions.
But Android booting stucks on Welcome screen with nice ANDROID leter
and sliding lights.
During this console from serial port works fine. On this console there
is warning: Unable to open an initial console.
But I thinks this is not a problem, because compiled binaries from
Embinux website gives the same warning but works fine.

Make executes without errors.

It is my first experience with Linux. I don't know where should I look
for a problem.
Please help. Thanks.