Angstrom + BB Xm

I had Ubuntu Maverick running on the BB but I decided to give Angstrom
a try. I used the narcissus.angstrom web compiler, after partitioning
the card in the same manner as booting Ubuntu, I copied the MLO, u-
boot.bin and uImage file (in that order) and all I get is the
BeagleBoard logo and nothing else. I have done this for the last 5
hours, changing sd cards and still nothing. The closest I have gotten
is in one try the Angstron logo came out and the process bar filled up
half way, it has never come out again..

I would provide logs but nothing appears on the screen (text). Please
any help would be appreciated, thank you.

If you have a serial cable, your bootlog over that might give some hints..


X11 is probably not set to start automatically. +1 for the serial cable suggestion

So I tried different boot scripts and I finally got one to boot and
show me some sort of errors, so the dmesg at boot ends with
'EXT3-fs (mmcblk0p2): error couldn't mount because of unsupported
optional features (240)'
'No fiesystem could mount root, tried : ext3'
'Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-

I am using the 720p tty0 boot script from narcissus.

It looks as though your root filesystem on mmcblk0p2 has been created as
ext4, whereas the kernel is trying to mount it as ext3.

I would guess this means that your BB kernel doesn't have ext4 support
(although you could try appending rootfstype=ext4 to your kernel parameters),
in which case the simplest recourse is to recreate the SD card's filesystem
as ext3.

Bye for now,