Angstrom Beagleboard Demo boot failure


I am trying to boot up Angstrom demo on the beagleboard xM rev A, however the boot freezes after “configuring network interfaces” and "hwclock: can’t open /dev/misc/rtc : no such file or directory

I am following these instructions to prepare the SD card:

And I am using the demo called: Angstrom-Beagleboard-demo-image-glibc-ipk-2011.1-beagleboard.rootfs.tar.bz2 from

I tried a build from but the boot still fails at the same spot.

The older version of the Angstrom demo booted just fine, and I have an older GNOME Angstrom build from narcissus that boot without a problem.

What do I need for the new Angstrom version so that it boots on my Beagleboard xM rev A???

Thank you

I have found a way around this error, but don’t know the cause still. When building from Narcissus, you need to select “Bootloader files (x-load/u-boot/scripts)” and copy the MLO*, u-boot-, and uImage from the /boot folder of the Narcissus download to the first partition on your SD card.

This loads Angstrom 2010 (even though 2011 was selected in the Narcissus options) and boots up. I’m still not sure why Angstrom 2011 fails, but at least I have something that will boot up with a desktop environment…

However, Just GNOME for now, XFCE seems to have other problems, doesnt start an x window session and “startx” just fails…

Anyways, after digging…a lot of digging…I found this post:

Which points to these instructions to take the MLO and u-boot.bin from the /boot folder:

Hope that will help someone else