Angstrom doesn't boot. Complains about a mounted root being readonly.

Hi,

I had a working Angstrom image. Today, I had executed opkg upgrade and
it did a whole of download/ installs.

When I rebooted beagle, the boot process is stuck. The last few lines
on the screen say they can't access the file system since its read
only.

Excerpt from the serial console:

....
mmc0: new high speed SDHC card at address
b368
mmcblk0: mmc0:b368 SDC 3.72
GiB
mmcblk0: p1
p2
kjournald starting. Commit interval 5
seconds
EXT3-fs: mounted filesystem with ordered data
mode.
VFS: Mounted root (ext3 filesystem)
readonly.
Freeing init memory:
196K
EXT3 FS on mmcblk0p2, internal journal

This is one of the log statements on the display:
Starting udev/etc/rcS.d/S03udev: line 50 can't create /tmp/uname: Read-
only file system

Any idea what is going wrong? Is the solution to make the file system
write enabled? How do I do that?

Regards,
Radha.

Hi Radha,

Verify your "bootargs" line, in the past.

Angstrom likes to see: ro rootfstype=ext2

where as

Debian/Ubuntu/Fedora likes to see: rw rootfstype=ext2

Regards,

The SD card I use is partitioned this way:

BeagleBoot: FAT32
BeagleAngstrom: ext3

printenv at uboot prompt gives me this info for bootargs:
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2
rootdelay=2 rootfstype=ext3 ro omap-dss.def_disp=lcd
omapfb.video_mode=1280x720MR-16@60

Should I change ro to rw? Would that help?

Regards,
Radha.

It works when I change the bootargs option to rw.

Thanks for the suggestions and help! Just makes me trust this
community even more, to remove my obstacles!

Regards,
Radha.

It works when I change the bootargs option to rw.

Thanks for the suggestions and help! Just makes me trust this
community even more, to remove my obstacles!

Regards,
Radha.

Good too hear it worked for you Radha..

PS, for people that later reference this post in Google searches, i
had those backwards between the two distributions. Need caffeine

Corrected... :wink:

> Angstrom likes to see: rw rootfstype=ext2

> where as

> Debian/Ubuntu/Fedora likes to see: ro rootfstype=ext2

Regards,