Angstrom drivers

I installed Angstrom dist. on BB and inthe directory /lib/modules/
2.6.32/kernel/drivers there are alotof modules for drivers.
And also in the directory /lib/modules/2.6.32/kernel/drivers/net/
wireless/rt2x00 there are module files for Ralink chip set wifi usb
dongle drivers. how can I install these drivers to system?
In the direct. rt2x00 there are 4 files like ;

rt2500usb.ko rt2x00lib.ko rt2x00usb.ko rt73usb.ko

When I use insmod command like
insmod rt2x00usb.ko
rt2x00usb: no symbol version for struct_module
insmod: error inserting './rt2x00usb.ko': -1 Invalid module format

also for modprobe ;
FATAL: Module rt2x00usb.ko not found.

these error messages.

So, How can I install this and other drivers from kernel ?Which step
is wrong ? or Is there any different way to install the module ?

plug in the usb dongle and the kernel will autoload them

Usb dongle is plugged and the lsusb output is ;

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 1a40:0101 TERMINUS TECHNOLOGY INC. USB-2.0 4-
Port HUB
Bus 001 Device 003: ID 1267:0210 Logic3 / SpectraVideo plc
Bus 001 Device 004: ID 1737:0078 Linksys WUSB100 RangePlus Wireless
USB Network Adapter ver. 2
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lsmod output is only;
Module Size Used by

nothing else

modprobe rt2x00usb

same error :frowning:
I serached different pages and saw something like "I must build the
kernel firstly" but I dont know if I understand truely. Do you have
any idea like this? My kernel image is Angstrom-Beagleboard-demo-
image-glibc-ipk-2010.3-beagleboard.rootfs.tar.bz2 that downloaded
Same errors for any other modules. I tried to use Huawei 3G modem
with ppp module but samely I could not install

Thanks for any help

I assume that this is not kernel image, but tar’ed content of rootfs. Kernel image usually looks like uImage_something.

Probably, you problem is that modules were build against different kernel version.

2010/12/27 ayunus <>

Do you get a kernel message when you tried the autoload, perhaps the same message? You can check with 'dmesg'.

The file you mention is a root file system, not a kernel. Be sure to make your kernel and module versions to match. You can find kernels and associated modules at that same link. The kernel is typically stored in the FAT partition, but the modules are expanded into the root file system.

OK you are rigtht not kernel. Thanks

I dont understant the "tried autoload" term. Is there any command for
this? When I plugged the dongle in dmesg I get;

usb 1-2.1: new high speed USB device using ehci-omap and address 8
usb 1-2.1: configuration #1 chosen from 1 choice

I download the kernel image (uImage) for revC4 latest version. Do I have to update the kernel image ?

2010/12/27 Mikhail Boiko <>

check the version of uImage. I think the correct one is 2.6.32