Angstrom fails to build qt4-x11

Hi,

I’ve successfully executed the 1st steps to have build with Angstrom for the BB black . After the

bitbake virtualenv/kernel

as I want to develop Qt app I then did a

bitbake qt4-x11

but after a while it ends with

david@BBb-deb:~/BBb/setup-scripts$ MACHINE=beagleboard bitbake qt4-x11

Parsing recipes: 100% |#####################################################################################################| Time: 00:04:31

Parsing of 2637 .bb files complete (0 cached, 2637 parsed). 3143 targets, 120 skipped, 0 masked, 0 errors.

WARNING: No recipes available for:

/home/david/BBb/setup-scripts/sources/meta-handheld/recipes-core/udev/udev_164.bbappend

/home/david/BBb/setup-scripts/sources/meta-intel/meta-fri2/recipes-core/tiny-init/tiny-init.bbappend

Build Configuration:

BB_VERSION = “1.17.0”

TARGET_ARCH = “arm”

TARGET_OS = “linux-gnueabi”

MACHINE = “beagleboard”

DISTRO = “angstrom”

DISTRO_VERSION = “v2012.12”

TUNE_FEATURES = “armv7a vfp neon cortexa8”

TARGET_FPU = “vfp-neon”

meta-angstrom = “angstrom-v2012.12-yocto1.3:b7f8207b94d9a0ece73ad212a193cb2c95bd17ee”

meta-oe

meta-systemd

meta-efl

meta-gpe

meta-gnome

meta-xfce

meta-initramfs

toolchain-layer

meta-multimedia

meta-networking

meta-webserver

meta-ruby = “angstrom-staging-yocto1.3:c24d2b6dfd00724b3182977e19a153492afe9343”

meta-kde = “master:316d9c27e72cfebc7618268f8766624ee3f5e18e”

meta-opie = “master:c242efc6ca55772a88602f1f8f94dff697b38430”

meta-java = “master:75dee76c7cfbf1418e5c581f50bb57b3282013f7”

meta-browser = “angstrom-staging-yocto1.3:011dbb273ac725e5a9e62ae36b8e538b2e9eb09c”

meta-mono = “master:adf47f078dbf788a80ff1398a15a4fd5a334d320”

meta-ros = “master:7e2cd2c0952ee35e30c8e3f9dc57f277d58419b8”

common-bsp = “danny:136a28e4d16a03ee9a5e51d6e378f1b80c618b28”

meta-ti = “angstrom-staging-yocto1.3:69132771c1332951f424beeeb54dcb70a8a73541”

meta-efikamx = “master:07f2a5c777b4f866985735303bc6d696592760a9”

meta-nslu2 = “master:8948458fe3ec2b3c713b2a13a87123b64e22b0d9”

meta-htc

meta-nokia

meta-openmoko

meta-palm = “danny:924338ee2d44987da71088da31e1cd31d3a9dfa9”

meta-handheld = “danny:d641e71a7c09cd24c72e690ad1981e49da612bcd”

meta-intel

meta-sugarbay

meta-crownbay

meta-emenlow

meta-fri2

meta-jasperforest

meta-n450 = “danny:98342e9e685ac8066f7fe2517fd382127a286648”

meta-allwinner = “danny:3603ce61c075d2f6a23dbe0bd71ee604f7eb24ea”

meta-raspberrypi = “danny:1ad98cf651054982c1a69576c1663285f0090034”

meta-minnow = “danny:f7c5a1b630a309f7430d95100d939e6c49714bbb”

meta-linaro = “danny:e6f8003b039335f7ec75edf9a9b7a84d2d1b911a”

meta = “angstrom-staging-yocto1.3:845fa230a19c835cdb5d886b75c03df88ca30987”

NOTE: Resolving any missing task queue dependencies

NOTE: Preparing runqueue

NOTE: Executing SetScene Tasks

NOTE: Executing RunQueue Tasks

ERROR: Function failed: libgles-omap3: LIC_FILES_CHKSUM points to an invalid file: /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/Graphics_SDK_4_05_00_03/TSPA.txt

ERROR: Logfile of failure stored in: /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/temp/log.do_configure.16847

Log data follows:

DEBUG: Executing python function sysroot_cleansstate

DEBUG: Python function sysroot_cleansstate finished

DEBUG: Executing shell function do_configure

find: `Binaries/’: No such file or directory

DEBUG: Shell function do_configure finished

DEBUG: Executing python function do_qa_configure

NOTE: Checking autotools environment for common misconfiguration

DEBUG: Python function do_qa_configure finished

ERROR: Function failed: libgles-omap3: LIC_FILES_CHKSUM points to an invalid file: /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/Graphics_SDK_4_05_00_03/TSPA.txt

ERROR: Task 463 (/home/david/BBb/setup-scripts/sources/meta-ti/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb, do_configure) failed with exit code ‘1’

Google is useless in this case as the TSPA.txt is indeed not present during the do_configure. a git pull didn’t helped neither.
Please advice.

DL

Had a step forward:

I’ve edited the

setup-scripts/sources/meta-ti/recipes-graphics/libgles/libgles-omap3.inc

to point to MD5 for a fake license file I’ve created.

Nevertheless, the beast is not dead :

ERROR: Function failed: do_compile (see /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/temp/log.do_compile.23468 for further information)

ERROR: Logfile of failure stored in: /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/temp/log.do_compile.23468

Log data follows:

DEBUG: Executing shell function do_compile

/home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/temp/run.do_compile.23468: line 96: cd: /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/Graphics_SDK_4_05_00_03/GFX_Linux_SDK/OGLES/SDKPackage/Demos/*/OGLES/Build/LinuxGeneric: No such file or directory

ERROR: Function failed: do_compile (see /home/david/BBb/setup-scripts/build/tmp-angstrom_v2012_12-eglibc/work/armv7a-vfp-neon-angstrom-linux-gnueabi/libgles-omap3-4.05.00.03-r33/temp/log.do_compile.23468 for further information)

ERROR: Task 464 (/home/david/BBb/setup-scripts/sources/meta-ti/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb, do_compile) failed with exit code ‘1’

NOTE: Tasks Summary: Attempted 3344 tasks of which 3342 didn’t need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

Summary: 1 task failed:

/home/david/BBb/setup-scripts/sources/meta-ti/recipes-graphics/libgles/libgles-omap3_4.05.00.03.bb, do_compile

Summary: There was 1 WARNING message shown.

Summary: There was 1 ERROR message shown, returning a non-zero exit code.

Any advice please ?

My advice is to use qt in the QWS mode when the qt is a server itself and it does not need any window system. In other words all you need to create qt applications is: a kernel which creates a node /dev/fb0, any console only file system with installed qt libraries. Any question don’t hesitate to ask me directly

Will be done,
Thank you for your answer.

hmm not sure how to contact you directly; your contact is not displayed here.

Lisarden : if having a minimal Angstrom environment is enough , I would indeed be interested to know how to set it up to have all the requirements you have described installed.

Still tried to install qt4-embedded --force-dépends but it ends with iconv and missing fonts errors.

Any idea ?

LIsarden : I didn’t found your contact anywhere, how to “ask you directly” ?

isn’t email a direct contact? :slight_smile:

I saw your question but I do not support Angstrom installer. I can explain how to build Qt manually and install it to a target. If you need Angstorm support then contact Koen

Hi Maxim,

For a reason I didn’t understood, your email wasn’t displayed, I also tried via Google+ also.
Anyway, I relied on Angstrom as this the preferance from the BeagleBone Black creators, but I just want to use the BBB to display my Qt app and use the 4D display Cape and sensors (I2C, analogs IO) so whatever is able to do it (Debian, Gentoo, Archlinux, etc) : I’m ok with your solution.

PS : I’ve been in touch with Koen but he seems to be unavailable now and asking such a question on #beagle is not always accepted (" Hardware only here" )

You should install an official image for BBB and then (I suppose) you should be able to install qtlib correctly by opkg

when you compile things manually some of dependencies can be missing

Well actually this is not the case: I’ve upgraded with the last Angstrom image and did, as described in my post, a “opkg-update + opkg install qt4-embedded --force-dependencies” which ended
with a message about missing fonts and iconv lib. Searching with opkg and Angstrom package website didn’t gave anything neither.

This is where I’m currently.