Angstrom- Mouse & Keyboard does not work

I have USB mouse and Keyboard which are connected through a USB HUB to
USB OTG on Beagle Board, but it does not work! Can anyone please help
me for this issue!?
-Thanks

Mouse works fine if i connect directly to USB OTG on Beagelboard
bypassing the HUB. But keyboard does not work by this also.

Bhargav,

Check the BeagleBoard Wiki and community FAQ:

http://www.elinux.org/BeagleBoard#OTG

http://www.elinux.org/BeagleBoardFAQ#USB_OTG_connection_.231

To use both mouse and keyboard, you generally need a self-powered hub,
i.e., a hub with its own external power supply.

Hope this helps,
John

Hey John,

It detects the keyboard when i do
# /sbin/lsusb
I am connecting the keyboard directly to the USB-OTG port, but still
it does not work.

Bhargav,

Have you tried using a self-powered hub?

I don't know why the keyboard shows up with lsusb but does not
function, but here's my guess: All USB devices are required to have a
low-power mode that requires at most 100 mA to operate. In this low
power mode, the USB device can tell the host how much current it
really needs to operate, typically up to 500 mA. Then the host can
determine whether or not it can power the device, and either switch it
to functional mode or leave it disabled. It's possible that your
keyboard requires more than 100 mA, so Ångström recognizes it as a USB
device, but won't power it up because the BeagleBoard cannot generate
enough current. 100 mA should be enough for most keyboards, but yours
may require more.

The BeagleBoard can only source 100 mA on the OTG port. I found that
this was enough to power my keyboard, or my mouse, or my hub plus my
mouse. It was not enough for the hub and keyboard, or all three. The
symptom in my case was that I got a continuous stream of diagnostics
on the serial port indicating that Ångström was continually connecting
and disconnecting the keyboard. Powering the hub from an external +5V
supply fixed the problem immediately.

John

It works now, Thanks

Bhargav,

To help the next person who comes along searching for this issue,
please post what you did to make it work.

My colleagues and I also find that with certain combinations of
bootloader and kernels, USB devices will list on lsusb but not
function after hard boot. After soft boot (e.g. by running reboot on
the command line) USB devices function normally.

Emir

This was the problem, why it was not working?
I have to connect keyboard/mouse through USB mini-A male to std A
female cable. Before I was connecting the HUB directly to the USB
OTG.