Angstrom passwords

Hi,
I’m new to the Beaglebone Black but didn’t have problems trying out several OS’s.
As Ubuntu was too slow for my taste I switched back to Angstrom. After loading the latest img to eMMC, several days in a row I could do update/upgrade without a problem until the Angstrom logo appeared. The login procedure was changed drastically as the automatic login was gone and replaced by the choice ‘mpd’, ‘xuser’ and ‘Other’. As other I tried ‘root’ but nothing worked. I could not login. I couldn’t find the correct passwords anywhere. Can someone help?
Thanks.

Hi Gabriel,

Access the board via SSH on the USB as root.

Add another user e.g. Gabriel & set the password.

You will see that the new user is instantly added on the GUI login screen as well and you can now login as that user.

Dave.

I'm having same issue!! No way to log into my BBB using Angstrom after
restoring from backup. I can't get past log in screen with "mpd", "xuser"
and "Other" options. Would greatly appreciate any help.

opkg install --force-reinstall angstrom-gdm-autologin-hack

Or create a password for the root user, which is greatly recommended anyway

opkg install --force-reinstall angstrom-gdm-autologin-hack

worked for me

Thanks for your answers but regrettably SSH has disappeared from the HTML pages I can access via USB. Any other way I can get there?

Gabriel.

Hi all,

problem solved by reloading latest img with ‘automatic login’ and creating a password for root. Through all the updates that password is kept and needed. No automatic login any more !

Gabriel.

The best thing to me about BeagleBone Black is its None.js server that is running all the time. You can leverage this to run commands even when you can’t SSH. I ran into your same issue after I did an opkg upgrade. I solved by creating a js file in could9 with the below script. Just run from could 9 and it will execute commands on your BBB!

// http://nodejs.org/api.html#_child_processes
var sys = require(‘sys’);
var exec = require(‘child_process’).exec;
var child;

// executes pwd
var command = “opkg install --force-reinstall angstrom-gdm-autologin-hack”;
child = exec(command, function (error, stdout, stderr) {
sys.print('stdout: ’ + stdout);
sys.print('stderr: ’ + stderr);
if (error !== null) {
console.log('exec error: ’ + error);
}
});

I upgraded from the command line on emmc using update / upgrade and was rewarded with a splash screen i cant get past…as above. I updated on March 17, 2014.

I have tried all the things on this page so far…1) cant get in to ssh (usb) because when i try it says that connection has been closed by remote, 2) the Cloud9 solution returns that it failed to download.

I am new to linux command line, its honestly why i bought this thing…to learn. right now i have a $65.00 paperweight with a cool splash screen but cant get beyond the password.

Why isnt there a generic password set on update as with other linux distros to avoid threads like this?

Forgive my newness i really am trying and not being lazy here…I have been all over the internet and I see what you have here echoed, but its not working for me. additional help would be appreciated.

If you do Ctrl + Alt + F1 it will give you a console at the login screen and IIRC “gdm.service restart” will bring the login screen back up.

-Wil

Also run
“opkg install --force-reinstall angstrom-gdm-autologin-hack” and it will fix the auto login issue. But i think you have to reboot for it to take effect. Note that I just copied and pasted right form the post you replied to.

-Wil

Thank you for the quick response Wil, much appreciated!!! I got called out of town and will try this when I get back to the house…again MUCH appreciated!

Had same problem. Following the “Getting Started with Beaglebone” book from Make seems to give this result. Was able to get to a console and add a user manually, and get around it.

Shouldn’t have to do this, though, honestly. This kit is aimed at beginners. Surely this sort of gotcha would have come up in testing…

-Michelle

I had the same login issue when I upgraded Angstrom (i.e., the “MPD” and “XUSER” login names). Thanks, Wilfredo, for the help. This is what worked for me:

  • Before you do anything, upgrade your packages: “opkg upgrade” (I did not have to run “opkg update” first for this to work for me. However, I think it makes sense to update the package list before upgrading.)
  • The, run the command: “opkg install --force-reinstall angstrom-gdm-autologin-hack”
  • Reboot
    With wireless mouse/keyboard installed and monitor hooked up, the BBB boots into the Angstrom GUI as root.

Carl

Wil, worked great!!! Thanks for your help!!!

Andrew

No problem