Another bricked board


All attempts to unbrick my B5 by booting off the SD have not yielded
any results. I did follow most procedures discussed on this mailing
list and on the elinux portal.

The SD card is formatted for FAT32 and the first file copied is the
MLO followed by the xloader (both specialized versions meant for
recovery per the elinux portal).

The byte 0x1BE has 0x80. So the boot flag seems OK.

It is the USB that powers my board. Keeping the User button (setting
the relevant Sysboot pin to be read by bootrom) pressed while
releasing the Reset button forces the bootrom to perform peripheral
boot by seeking the USB first.

But it just cant seem to go past the USB.

I was hoping for a PC-BIOS like behavior where bootable media would be
sought out in succession and in the order in which they were specified
in the BIOS.

I haven't tried this as of yet, but is an external power supply
required for unbricking via MMC/SD?


The way we work with these boards in the facotry is to test them using DC power and not USB power. We have always been able to unbrick the boards that people have sent it. I suggest that you try this with the DC power.


Hi Gerald,
Just as you external power supply did the trick. My B5 is
back in business.


Glad it worked for you!