Application error

I have the angstrom distribution on my beagleboard, but I am having
problems running any of the applications it came with. Whenever I open
an application is says "application error" then it wants me to get bug-
buddy. I just got a usb to ethernet adapter and I want to browse the
web, but I cannot open epiphany or firefox. Also I would like to input
that abiword also will not open up without an error. Suggestions would
be greatly appreciate.

Thanks

Could try upgrading u-boot to 2008.10? There's an updated version at http://www.angstrom-distribution.org/demo/beagleboard/u-boot.bin

regards,

Koen