Atrix lapdock BBB screen resolution

Hi,

BBB with last june 20 build running fine on atrix lapdock.

Works, but I only get a resolution <800 x 600. Something 7xx x 5xx.

How do I get the lapdock full resolution of 1366 x 768?

Thanks.

In Angstrom, you can edit the resolution under the settings. I believe it’s something like System > Preferences > Monitors. The latest image should allow you to select various supported resolutions.

This website lists the supported resolutions as well:
http://circuitco.com/support/index.php?title=BeagleBoneBlack_HDMI

I use to have some problems with the screen resolution as the EDID information was not received by my BBB.

You could have a look to my thread:
https://groups.google.com/forum/?fromgroups#!searchin/beagleboard/resolution|sort:date/beagleboard/Cl7rGqful_w/A4DTlAVm0bMJ

Hi,

i don’t get any resolutions to choose there.

Try this http://circuitco.com/support/index.php?title=BeagleBoneBlack_HDMI#Default_Resolutions

Sounds like the Atrix has no EDID information.

Gerald

root@beaglebone:/sys/class/drm/card0/card0-HDMI-A-1# parse-edid edid
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc

Identifier “MotoAttach”
VendorName “MOT”
ModelName “MotoAttach”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

HorizSync 30-85
VertRefresh 50-75

Max dot clock (video bandwidth) 150 MHz

Block type: 2:0 3:fc

DPMS capabilities: Active off:no Suspend:no Standby:no

Mode “1366x768” # vfreq 60.000Hz, hfreq 48.000kHz
DotClock 72.000000
HTimings 1366 1380 1436 1500
VTimings 768 769 772 800
Flags “+HSync” “+VSync”
EndMode

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc

EndSection

It will default to a resolution that supports the audio, CEA resolution. If you want access to all resolutions you need to follow the instructions here:

http://circuitco.com/support/index.php?title=BeagleBoneBlack_HDMI#Default_Resolutions

You should then be able to see them in the System->Preferences->Monitors menu after a reboot.

Make sure you are using the latest image…

Gerald

I am using the latest image now. Now there is no video after boot on console 2 at all. Console 1 shows me a terminal.

It worked with the 5.27. image, but only one low resolution an no way to change.

Now i got:

optargs=quiet drm.debug=7 capemgr.disable_partno=BB-BONELT-HDMI
video=HDMI-A-1:640x480@60

in uEnv.txt (no SD-Card, internal storage, changed via SSH).

No video. After the boot, there is the BB-Logo and after that console 2 dead, console 1 terminal.

dmsg drm part shows:

[ 0.640695] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 0.689315] [drm:drm_detect_monitor_audio], Monitor has basic audio support
[ 0.689350] [drm:tilcdc_crtc_mode_valid], mode 720x576@50 pixel-clock 27000 audio true cea true can_output true
[ 0.689379] [drm:drm_detect_monitor_audio], Monitor has basic audio support
[ 0.689397] [drm:tilcdc_crtc_mode_valid], mode 720x480@60 pixel-clock 27000 audio true cea true can_output true
[ 0.689421] [drm:drm_detect_monitor_audio], Monitor has basic audio support
[ 0.689439] [drm:tilcdc_crtc_mode_valid], mode 640x480@60 pixel-clock 25175 audio true cea true can_output true
[ 0.689464] [drm:drm_mode_debug_printmodeline], Modeline 9:“1366x768” 63 75500 1366 1380 1436 1500 768 769 772 800 0x40 0x5
[ 0.689494] [drm:drm_mode_prune_invalid], Not using 1366x768 mode 11
[ 0.689517] [drm:drm_mode_debug_printmodeline], Modeline 8:“1366x768” 60 72000 1366 1380 1436 1500 768 769 772 800 0x48 0x5
[ 0.689545] [drm:drm_mode_prune_invalid], Not using 1366x768 mode 11
[ 0.689571] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] probed modes :
[ 0.689590] [drm:drm_mode_debug_printmodeline], Modeline 12:“720x576” 50 27000 720 732 796 864 576 581 586 625 0x40 0xa
[ 0.689619] [drm:drm_mode_debug_printmodeline], Modeline 11:“720x480” 60 27000 720 736 798 858 480 489 495 525 0x40 0xa
[ 0.689648] [drm:drm_mode_debug_printmodeline], Modeline 10:“640x480” 60 25175 640 656 752 800 480 490 492 525 0x40 0xa
[ 0.689677] [drm:drm_setup_crtcs],
[ 0.689695] [drm:drm_enable_connectors], connector 5 enabled? yes
[ 0.689714] [drm:drm_target_preferred], looking for cmdline mode on connector 5
[ 0.689731] [drm:drm_target_preferred], looking for preferred mode on connector 5
[ 0.689749] [drm:drm_target_preferred], found mode 720x576
[ 0.689765] [drm:drm_setup_crtcs], picking CRTCs for 2048x2048 config
[ 0.689788] [drm:drm_setup_crtcs], desired mode 720x576 set on crtc 3

Have you tried something other than 640x480? The BeagleBone Logo means that everything is basically working, but the resolution in the kernel does not make the Atrix happy. The resolution change in the uENV.TXT file from what I have seen only sets the LOGO resolution. You can see the LOGO size change as you change resolutions. When the kernel reads the EDID, it takes over from there.

I have an Atrix, but I have not used it in a long while. I didn’t like the screen. I will see if I can find it, I hope, and I can have one of my guys work with it to see what he can come up with.

Gerald

Would you mind clarifying what you are referring to as “console 1” and “console 2”?

CTRL-ALT-F1 and CTRL-ALT-F2

Actually my uEnv.txt in /media/BEAGLEBONE consist of:

optargs=quiet drm.debug=7 capemgr.disable_partno=BB-BONELT-HDMI
video=HDMI-A-1:1280x768@60

I tried many possible resolutions from here:
http://circuitco.com/support/index.php?title=BeagleBoneBlack_HDMI#Default_Resolutions

The BB-logo at the start is alway the same size. Roughly 80% width of my screen of the atrix.

Still no X.

That file is created by reading the uENV.txt file in the FAT partition. It gets created on boot up. So, changing that does nothing.

Gerald

???

powered up …

login as: root
root@192.168.222.22’s password:
root@beaglebone:~# mount | grep BEAGLEBONE
/dev/mmcblk0p1 on /media/BEAGLEBONE type vfat (rw,nosuid,nodev,relatime,fmask=0022,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro)
root@beaglebone:~# lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
mmcblk0boot0 179:8 0 1M 1 disk
mmcblk0boot1 179:16 0 1M 1 disk
mmcblk0 179:0 0 1.8G 0 disk

-mmcblk0p1 179:1 0 70.6M 0 part /media/BEAGLEBONE
`-mmcblk0p2 179:2 0 1.7G 0 part /
root@beaglebone:~# cat /media/BEAGLEBONE/uEnv.txt
optargs=quiet drm.debug=7 capemgr.disable_partno=BB-BONELT-HDMI
video=HDMI-A-1:1280x768@60

Everything I put in there survives a boot.

From what I see it is the right disk. There is no sdcard inside my BBB.

OK. I stand corrected. Did it work?

Gerald

Hi,

Nope. It didn’t. None of the resolutions i tried. The logo is always the same size.

Bedtime now. Maybe you can try with your lapdock. Cu. Holger.

We did. It does not work.

5_08 image does however work.

And if you change the uENV.txt file in the FAT partition, the logo changes size.

Gerald

Did this ever get fixed? I’m running a 3.14 archlinux arm kernel and am running into the same problem. Which image is the “5_08” image?

Thanks a lot,
Peter Chinetti

No joy on getting the full 1366x768 but after quite some fiddling I’ve at least got 1360x768 working on the Motorola Atrix Lapdock, representing a significant improvement over the defaults.

BeagleBone Black version

I have a BeagleBone revB (with the 2GB on-board storage) and used the Angstrom Distribution (BeagleBone Black - 2GB eMMC) 2013-09-04 from http://beagleboard.org/latest-images/

/etc/angstrom-version

`
Angstrom v2012.12 (Core edition)
Built from branch: angstrom-staging-yocto1.3
Revision: 2ac8ed60f1c4152577f334b223b9203f57ed1722
Target system: arm-angstrom-linux-gnueabi

`

/media/BEAGLEBONE/ID.txt

`

Cloud9 GNOME Image 2013.09.04
`

Linux Terminal: uEnv.txt

To improve the resolution of the ttys outside of X11 (available via CTRL-ALT-F1, … FN), add the video parameter to /media/BEAGLEBONE/uEnv.txt as shown:

/media/BEAGLEBONE/uEnv.txt

optargs=quiet drm.debug=7 capemgr.disable_partno=BB-BONELT-HDMI video=HDMI-A-1:1360x768M@60

You can check current kernel params via cat /proc/cmdline

X: /etc/X11/xorg.conf

The EDID info for the lapdock’s monitor doesn’t seem to have timings / resolutions that work. After fiddling, for awhile I found two modeline improvements over the 720x576@50 mode that required editing xorg.conf. Note that I defined a “Monitor” section for the “MotoAttach” identifier, then pointed the existing “Screen” definition to this new monitor. You could also drop the Modelines into the default monitor config and leave the “Screen” alone.

Here’s my entire /etc/X11/xorg.conf:

`

`
Section “Module”
Load “extmod”
Load “dbe”
Load “glx”
Load “freetype”
Load “type1”
Load “record”
Load “dri”
EndSection

Section “Monitor”
Identifier “Builtin Default Monitor”
EndSection

Section “Monitor”
Identifier “MotoAttach”
VendorName “MOT”
ModelName “MotoAttach”
HorizSync 30-85
VertRefresh 50-75

Modeline “1360x768@60” 84.50 1360 1392 1712 1744 768 783 791 807 +hsync +vsync
Modeline “1280x720@50” 74.25 1280 1720 1760 1980 720 725 730 750 +hsync +vsync
EndSection

Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “modesetting”
EndSection

Section “Screen”
Identifier “Builtin Default fbdev Screen 0”
Device “Builtin Default fbdev Device 0”
#Monitor “Builtin Default Monitor”
Monitor “MotoAttach”
DefaultDepth 16
EndSection

Section “ServerLayout”
Identifier “Builtin Default Layout”
Screen “Builtin Default fbdev Screen 0”
EndSection
`

`

These pages were helpful to varying degrees in finding some Modelines that work better:

EDID info wrong?

Here’s the reported EDID info, which does not work when put into xorg.conf, gathered from this command:

parse-edid /sys/class/drm/card0/card0-HDMI-A-1/edid

`

`
parse-edid: parse-edid version 2.0.0
parse-edid: EDID checksum passed.

EDID version 1 revision 3

Section “Monitor”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc

Identifier “MotoAttach”
VendorName “MOT”
ModelName “MotoAttach”

Block type: 2:0 3:ff

Block type: 2:0 3:fd

HorizSync 30-85
VertRefresh 50-75

Max dot clock (video bandwidth) 150 MHz

Block type: 2:0 3:fc

DPMS capabilities: Active off:no Suspend:no Standby:no

Mode “1366x768” # vfreq 60.000Hz, hfreq 48.000kHz
DotClock 72.000000
HTimings 1366 1380 1436 1500
VTimings 768 769 772 800
Flags “+HSync” “+VSync”
EndMode

Block type: 2:0 3:ff

Block type: 2:0 3:fd

Block type: 2:0 3:fc

EndSection
`

`

Change X resolution from command line
These commands are convenient to execute over SSH or serial connection while flailing at xorg.conf modelines.

Failsafe mode

`

export XAUTHORITY=ls /var/run/gdm/auth-for-root-*/databaseexport DISPLAY=:0.0 xrandr --output HDMI-0 --mode 720x576 --rate 27

`

Restart X
(faster than rebooting)

`
systemctl restart display-manager

`