Attempt to Expand Root Partition Results in SD Card That Cannot Boot


I have followed this tutorial ( step by step several times, yet always end up with an SD card that is no longer bootable. I do the whole fdisk deleting and remaking the second partition thing, but then when I reboot, so that I may subsequently run resize2fs, the BBB doesn’t reboot, the four USR LEDs light up and it just stays like that forever and then I need to reformat the card. What am I doing wrong?

I’m using a 32gb PNY SDHC card. I’ve tried formatting it as FAT32 as well as EXFAT (due to the 4gb file size limitation on fat32) from my Mac but neither solve the problem. I’m trying to run Angstrom. I was considering changing to Ubuntu or Arch but I am under the impression that the various GPIO libraries wouldn’t be compatible (adafruit, bonescript). I have also considered booting from usb since I’ve heard SD cards can be unreliable

any help would be much appreciated

Jack, first let me point out that I am a newbie here. I found that the instructions for expanding the partition only applied “worked” on the Debian and Ubuntu images off the Beagleboard website /links. It consistently failed when trying it on the Angstrom. I also noticed that the way the boot and image files were stored on the Angstrom images were setup different as well. Assumption being… fdisk screws up the boot partition.

Dave L.