Audio Cape with Beaglebone Black

For anybody like me, vaguely understanding what’s going on, and ending up here: I built 3.8.13-bone39 from Robert Nelsons github site. A slightly modified version of cody’s patch above is already applied. All you need to do is enable the audiocape in uEnv.txt (my cape is Rev 1A), by adding this line (or adjusting your optargs line, of course):


HDMI audio is automatically switched off (no need to disable HDMIN) when the cape is detected. The display continues to work.

Nice, and big thanks to all who made this work!

Now I’ll have to find out why ethernet doesn’t work if a usb-keyboard is attached, why lsmod doesn’t produce any output, and if I can attach a usb sounddevice :wink: