Audio via HDMI on Debian image 2016-01-24

I am unable to send audio over HDMI to my monitor.

The video is active over HDMI and the volume is turned up.

Results from various commands:

Debian Image 2016-01-24

/sys/devices/platform/bone_capemgr/slots
0: PF---- -1
1: PF---- -1
2: PF---- -1
3: PF---- -1
4: P-O-L- 0 Override Board Name,00A0,Override Manuf,cape-universaln

I have also tried replacing overlay 4 with cape-univ-hdmi with same results.

cat /proc/asound/pcm
00-00: HDMI hdmi-hifi-0 : : playback 1 : capture 1

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Black [TI BeagleBone Black], device 0: HDMI hdmi-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

“amixer -c 0” and “amixer -c 0 controls” has no output

“speaker-test -D plughw:0,0 -c2” creates no sound.

Thank you,

Note that only certain resolutions support Audio.

http://www.elinux.org/Beagleboard:BeagleBoneBlack_HDMI#Supported_Resolutions

Gerald

Thank you Gerald. I meant to include the partial listing of uEnv.txt:

#In the event of edid real failures, uncomment this next line:
cmdline=coherent_pool=1M quiet cape_universal=enable video=HDMI-A-1:1280x720@60e

Attached my android phone to the cable - it has a micro hdmi port - and listened to a youtube video on the monitor. The cable and monitor check out.

additional information:

amixer -c 0 info

Card hw:0 ‘Black’/‘TI BeagleBone Black’
Mixer name : ’ ’
Components : ’ ’
Controls : 0
Simple ctrls : 0

additional information:

aplay -L

null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=Black
TI BeagleBone Black,
Default Audio Device
sysdefault:CARD=Black
TI BeagleBone Black,
Default Audio Device
dmix:CARD=Black,DEV=0
TI BeagleBone Black,
Direct sample mixing device
dsnoop:CARD=Black,DEV=0
TI BeagleBone Black,
Direct sample snooping device
hw:CARD=Black,DEV=0
TI BeagleBone Black,
Direct hardware device without any conversions
plughw:CARD=Black,DEV=0
TI BeagleBone Black,
Hardware device with all software conversions

working with USB speakers, but not with HDMI audio.