Barebox not booting from MMC on Beagle board

Hi everyone,

I’m new on this group, so I apologize if this question has been answered in one of previous discussions. I’ve searhed through the messages, but I couldn’t find the answer.

I’m working on Beagle board, EBV Beagle, namely. I’m trying to switch to Barebox bootloader from standard X-loader / U-boot pair.

I’ve checked out barebox source from


First, I’ve built MLO:

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- omap3530_beagle_xload_defconfig

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi-

then barebox.bin:

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- omap3530_beagle_defconfig

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi-

Both MLO and barebox.bin are copied in 128MB boot partition on SD card. I made Beagle board boot from SD card (holding USER key down when powering on), but all I got in serial terminal was:

nand: Trying ONFI probe in 16 bits mode, aborting !
nand: NAND device: Manufacturer ID: 0x2c, Chip ID: 0xba (Micron ), 256MiB, page size: 2048, OOB size: 64
omap-hsmmc omap3-hsmmc0: registered as omap3-hsmmc0
mci0: detected SD card version 2.0
mci0: registered disk0
malloc space: 0x87bff400 → 0x87fff3ff (size 4 MiB)
booting from MMC

As far as I can understand, MLO has sent those messages and tried to boot barebox from MMC, but then it all stopped. Has anyone had the similar situation?

I have also enabled kernel low level debug messages and selected UART port 3 as OMAP debug UART port.

Any idea and suggestion how to solve this issue is more than welcome.



I’ve solved the problem. It was my mistake, as I was copying barebox.bin generated in source directory instead of barebox_flash_image that is actually a link to the file arch/arm/pbl/zbarebox.bin.