Bash: ./ Permission denied error in configuring DSP

I am following to configure
DSP on BeagleXM.

When i execute ./, i get an error

aadeesh@ubuntu:~$ ./
bash: ./ Permission denied

I installed the "Requirements" in,
But still the same error appears.

Also i could not find the file to do the modifications.
I am using Ubuntu 10.10 as my Host and ubuntu-10.10-r4-minimal-armel
on beagle.

Please help.

It sounds like you need to mark the file as executable before running it:

  chmod 0755

Bye for now,

Make sure you are actually in the 2.6-stable directory.

I've tried to make the script as idoit proof but let me know if you
run into anything else..


Sorry, i did not understood "2.6-stable directory" ?
Your idiot proof scripts certainly helps a beginner like me.


Then where did you get the "./" script?

You just can't download the script by itself, you need the bzr repo,
as the script requires other files for data/control..

bzr branch lp:~beagleboard-kernel/+junk/2.6-stable

(for bzr haters, i'm planning a conversion to git on github, which
i've done for the devel tree's) :wink:

then: cd 2.6-stable/

then "./" will work..

Looking at your original email, you were asking about DSP, well the
10.10-r4 already has the correct kernel.. (main reason i updated the
image on feb 5th).

So you just need to run the "./" from my
2.6-stable to get the dsp libs..



aadeesh@ubuntu:~/2.6-stable$ ./
+ Detected build host [debian-] line 32: syntax error: unexpected end of file


aadeesh@ubuntu:~/2.6-stable$ ./ line 22: syntax error near unexpected token `fi'


Looks like you screwed up the "" when you copied it from

post it to and i'll comment on it..


I just copied as


Also is as follows

That's what i figured.. I added some more checks to warn users when
they forgot to modified the "#CC=arm-linux-gnueabi-"

The script doesn't care which of the many cross compilers you use...
It just needs to know where to find it..

So modify the CC variable accordingly..

Otherwise, no longer needs the CC variable so i
removed that check upstream..

(it use to compile stuff, now days it just packages the codec's..)


Thanks. Its working now.
Sorry for my silly questions.

You are like my Mentor.

Thank You.

Hello Robert,

I have like the following

#copy as “” and tweak for your system

ARCH=$(uname -m)

#ARM Native gcc compiler (running gcc on arm target)

if [ “x${ARCH}” = “xarmv7l” ] ; then
#Native arm gcc compiler



#ARM GCC CROSS Compiler:
if CC is not set, a known working linaro based gcc compiler will be downloaded and utilized.



###OPTIONAL: LINUX_GIT: specify location of locally cloned git tree.

Uhh.. Please don't translate the error message..

Run "./" and paste the FULL terminal output of the run


ohh sorry, here is the output



10 Aralık 2013 Salı 18:16:00 UTC+2 tarihinde RobertCNelson yazdı:

Remove the extra "if" you un-commented out in the file..

To see which if, just use meld: "meld"