BB AI-64 does not show on tether to PC on first startup.

i never received a micro sd card with my AI-64. is there an image i can get somewhere i can put on a micro sd and try to first boot?

Here you go:

Thank you, I will try that… but since I am flying blind with no cable to hook up a monitor to the BB… does it make sense to try this blind through PC tether or just wait for my monitor cable?

So out of the box, the AI64 has a pretty old image, i’m trying to remember what exactly worked… over the usb type-c you should get a serial/Ethernet connection once the board boots up… on windows this should, on mac (linux both)…

Any newer images, you will have to hold the usr button, toggle reset, lift off usr button as the original u-boot was really ‘broken’. We fixed a lot of things since then, (supporting 3 different memory types)…

Best to grab the xfce or minimal “flasher” from here: ARM64 - Debian 11.x (Bullseye) - Monthly Snapshots - 2023-10-07 and get that version of u-boot on the eMMC updated

and do this dance:

  • insert microsd
  • insert power
  • push and hold usr button
  • toggle reset
  • let go of usr button
  • led’s should start blinking
  • led’s should start a chase, cylon, back and forth pattern…
  • board will stop after 5-10 minutes (depending on image)
  • remove microsd
  • re-power board
  • wait for usb connection



My issue is that I can’t tell if it ever boots up just by watching a bunch of LEDs flashing. The host PC through the USB to USB c has no idea there us a device connected to it even after an hour of just sitting there.

It can see any other USB I plug into it even if it can’t recognize it. It still acknowledged the presence. But the BB ai-64 us not visible

Are you sure the USB cable you are using is a data cable and not just a power cable ?

One led indicates power and constantly on. Another one should periodically blinking, which means that os is booted up.
You need to get the 16GB or more SD card. Flash .img image from this archive: with Balena Etcher with all the steps described above.

One more thing: you should provide anough power to the board. Im using the 3Amp 5Volts DC wall adapter with barrel jack, because don’t want to cook my laptop.
I guess it would have more sense if you provide all the steps you made so far, and your setup as well. Things are complicated with this platform)

I would echo that. The AI64 is quite power hungry. Best to use a good external 5v supply, at least 3A. Powering from a standard USB port can be problematic. You will find it will power up, but later reboot due to the power dipping. You should be ok with a good USB C to USB C cable if your PC has a suitable port. I would be wary of plugging it into a standard USB A port.

1 Like

the LED closest to the UART0 pins is blinking constantly, no other LEDs come on. it just remains in that state indefinitely. i also have the miniHDMI cable connected to my other monitor and the monitor does not see the board either

I am using a USB to C plugged into my powered USB block which also supports my USB to Ethernet. the Barrel plug alone does basically nothing but dim the LED when plugged in

thank you but i have the BB AI-64, there is no USR button. there is RST PWR BOOT

Sorry, always going from memory… BBB’s have ‘usr’… BBAI-64 was corrected to show ‘BOOT’. :wink:

Barrel jack should not dim the leds, otherwise it means that polarity is wrong or wrong voltage. Center pin should be positive.
To successfully use HDMI you need to get active 4K miniDP to HDMI adapter, like this one:

Anyway you need to flash lastest image:
Insert sd card with the image, hold BOOT button, insert power, wait for about 20 seconds, leds should start sequential pattern, release the BOOT button. Wait about 20 minutes or so till leds turn off.

Ok I will try all that. Thanks

so i tried to use the 5v center positive 3a wall adaptor… the wall adaptor light goes on but the AI64 led does not… unless i use the USB for power. then it does go on… but it doesnt blink or do anything else. no other led lights come on

So you extracted the .img file, burned it to the sd card with Balena Etcher, inserted sd card into unpowered bbai64, hold the BOOT button, plug the power in, wait for 20 sec and nothing happened?

Use the raspberry pi imager and burn the official flasher image onto your SD card. Try a different card if that does not work. I don’t believe the ai64 is flaky regarding the brand of SD card so it should not be an issue. Card might have an issue. If that RCN flasher does not boot your board is more than likely dead. Connect a ttl to USB to the debug port to verify that it is actually dead.

Thanks, with the holidays it’s hard to get things done but I will try again. I may have missed something along the way. I am an electrician and have a good grasp of technology integration but admit I am not very experienced with Linux. Everything I do deals with industry and utility scale. So now I’m just going to have to get good at SBC systems and Linux. Big difference from ladder logic and PLCs

Yes, it sure is. Depending on the application and if it is a critical application a plc might be the best choice. Linux is nice however it is way too complex for many applications. Years ago it was totally opposite, I could place an I/O / Motion control card on the ISA bus with DOS 6.2 and have a very robust and ready for testing system up in a fraction of the time it took to code using a ladder. Now days, I hate to say this but,.

Back then I wish the multicores and the ability to run multiple threads and processes was around. That is a very strong point for running a SBC.