BB Black - eMMC + mSD + USB HDD = fs corruption on mSD/USB HDD?


I’m fighting a weird symptom on my BeagleBone Black (Rev A5C):

I flashed Ubuntu 13.04 into the eMMC because I’d like to use it as a in-house storage server for BTSync and Samba. Since Ubuntu leaves me with “only” ~1.1GB available space in the / partition within the eMMC I slapped in a mSD Card (SanDisk Class 10 32GB) which mounts to /home and, later on, connected a USB hard drive (500GB Seagate drive in a Sharkoon QuickPort XT dock).

The problem I can’t resolve is like this:

Running the BBB with just the eMMC and the mSD (already inserted prior to powering on because it doesn’t get recognized once the system is up) is perfectly fine - well, for as long as I flag the mSD as “0 1” in the fstab - with “0 2” on the end of the fstab line it somehow “soft bricks” on boot (hangs, and not even SSHd has loaded up). However, the system just works fine.

Now, when I connect the USB hard drive I run into a severe problem:

  • I boot the BBB off the eMMC with the mSD inserted
  • Once booted I add the USB hard drive into fstab (using the UUIDs, of course)
  • I create the /media/sharkoon mountpoint and run a “sudo mount -a” to mount the drive
  • I say “sudo reboot” or “sudo halt” (doesn’t matter)
  • Upon system boot and ssh-ing back in I’m greeted with a error message that the home directory couldn’t be found.
  • Investigating the log files shows that /dev/mmcblk0p1 (the /home partition on the mSD) and /dev/sda1 got reported as “contains a filesystem with errors”
  • fsck’ing the filesystem does the repair (doesn’t even show it did anything other than going through the 5 steps)
  • “sudo mount -a” brings everything back to normal.
  • Continuing with this setup will eventually run into a “soft brick” (system boot stalls at some point and I can’t get in anymore)

Funny thing is the system logs do NOT show any errors which would explain why the file system corruption happens, all I see is that the attempt to mount the USB hard drive happens rather late (near the end of “/var/log/dmesg”, but I’d say that’s about to be expected as the drive first needs to spin up and get ready).

Since this inconvenience renders the intended usage pointless at the moment…

Does anyone have an idea about why it happens and what I could possibly do to get around it?

I’m not Linux n00b by any means, but I fail to get behind this problem here.

Thanks for any meaningful input on the topic,

  • J.

Did you try a different type of SD cards? For example, I have corruption problems with kingston cards like the ones delivered with the BB white. Now I use Transcend 4 GB cards and have no problem yet.


Well, I actually “gave in” and a) flashed the eMMC back to Angström Linux and b) turned the SanDisk 32GB Class 10 into a bootable mSD card with Ubuntu on it (from

Now everything works fine. The mSD boots up and the attached USB hard drive gets mounted properly, I didn’t see any filesystem corruption anymore at all - and the system runs stable as a rock.

Since there’s no word from some official Engineer about it: I can only assume that the BeagleBone doesn’t like it when eMMC + mSD + USB is used together. Don’t quote me on it, it’s just what I think as eMMC + USB storage device or mSD + USB storage device works just fine, while things go south when you try to combine all three like I tried initially.

As a side note in case some official read the posts in this G-Groups “Forums”:
Sirs, compared to the Raspberry site yours is a unholy mess and a lot of information that would be nice to know about is missing. I know that “you get what you pay for”, but keeping in mind that the Raspberry goes for about the same price, the support they offer through their forums and e-linux Wiki is “several orders of magnitude more Premium” than the show you run here.

I don’t believe you are being entirely fair. Raspberry Pi has been out since 2011, BBB has been out for what, six months or so? When something is new, it takes time to build up a community of users. Also, nobody on the planet has more than six months experience with BBB, there are people with two and a half years of experience on the RP. For as young as this project it, I believe it is doing exceptionally well.