BB doesn't boot after changing boot configuration

I changed to boot from MMC in terms of
Section IV. Setting Up Your Automatic Boot. But my BB doesn't boot any
more, I think the content is old it may not work for C4. Here is
booting message,

   21.887176] VFP support v0.3: implementor 41 architecture 3 part 30
variant c rev 1
[ 21.896606] registered taskstats version 1
[ 21.917053] Console: switching to colour frame buffer device 80x30
[ 21.932769] clock: clksel_round_rate_div: dpll4_m4_ck target_rate
[ 21.941619] clock: new_div = 9, new_rate = 48000000
[ 21.953918] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[ 21.962738] Waiting for root device /dev/mmcblk0p2...
[ 21.986083] mmc0: new SD card at address aaaa
[ 21.993408] mmcblk0: mmc0:aaaa SD02G 1.84 GiB
[ 22.000549] mmcblk0: p1 p2
[ 22.079376] EXT3-fs warning: mounting unchecked fs, running e2fsck
is recommended
[ 22.092315] kjournald starting. Commit interval 5 seconds
[ 22.102386] EXT3 FS on mmcblk0p2, internal journal
[ 22.110198] EXT3-fs: recovery complete.
[ 22.117004] EXT3-fs: mounted filesystem with ordered data mode.
[ 22.126129] VFS: Mounted root (ext3 filesystem) on device 179:2.
[ 22.135498] Freeing init memory: 204K
[ 22.153106] Kernel panic - not syncing: No init found. Try passing
init= option to kernel.

My MMC has u-boot.bin, ramdisk.gz, uImage.bin and boot.scr.
I try to go back to ram disk file system. It doesn't work as well. Can
anyone help me out? here is my boot environment by printenv

mmcroot=/dev/mmcblk0p2 rw
mmcrootfstype=ext3 rootwait
nandroot=/dev/mtdblock4 rw
mmcargs=setenv bootargs console=${console} vram=${vram}
omapfb.mode=dvi:${dvimode} omapfb.debug=y omapdss.def_disp=$
nandargs=setenv bootargs console=${console} vram=${vram}
omapfb.mode=dvi:${dvimode} omapfb.debug=y omapdss.def_disp=$
loadbootscript=fatload mmc 0 ${loadaddr} boot.scr
bootscript=echo Running bootscript from mmc ...; source ${loadaddr}
loaduimage=fatload mmc 0 ${loadaddr} uImage
mmcboot=echo Booting from mmc ...; run mmcargs; bootm ${loadaddr}
nandboot=echo Booting from nand ...; run nandargs; nand read $
{loadaddr} 280000 400000; bootm ${loadaddr}
bootargs=console=ttyS2,115200n8 console=tty0 root=/dev/mmcblk0p2 rw
rootfstype=ext3 rootwait omapfb.video_mode=1024x768MR-16@60
bootcmd=mmc init 0; fatload mmc 0 0x80300000 uImage.bin; bootm

I once had to wait about 35 minutes for the board to boot on it's
first time....

there is really an error not syncing: No init found

have you tried recovering your card FS?? run fsck.ext3 (in a linux
machine) on that sd card...

Later, I tried to load ramdisk.gz to memory. So I can go back to ram
fs. I don't know how to set init if I use
fs in MMC. When I look at the BB environments, it hasn't loading
ramdisk, but old veriosn does. The BB documents/links lack updates to
handle C4