BB-xM-Rev C :mmcblk0: error ; end_request: I/O error messages while booting

Hi there!

I've recently bought a BeagleBoard xM Rev C, and unfortunately I took
off the SDCard from the board while it was powered on. It seems that
it broke the software installed on the card, so now i'm trying to
recover the original status on the card.

I've done this by following the instructions given on

I have also tried another alternative:
i've download the .img file from
and then i've "dd'd" it to the SDCard:

$sudo dd if=/path/to/xMRevCProduction4-25-2010.img-file of=/dev/sdc

This copied the files on the boot and the Angstrom distributions.

But when i insert this SDCard on the BB-xM-RevC, some error messages
display while the system is booting (i get this messages through the
minicom app). The thing is that even though those error messages, i
get to login to the system (i haven't worked enough time with it to
know whether those errors create problem or not)
I don't want to paste all the booting output (i can send it to you if
you want), so below you can find some error messages.

Has anyone among you found these issues?? do you consider that i can
ignore them or they need to be fixed (trying to recover the SDCard
properly so i don't get any error message while booting)??

Thank you very much for your time and attention and congratulations
for you all for the work done in this forum!


[ 12.046966] input: Microsoft Microsoft Basic Optical Mouse v2.0
as /devices/platform/ehci-omap.0/usb2/2-2/2-2.5/2-2.5:1.0/i3
[ 12.067871] generic-usb 0003:045E:00CB.0002: input: USB HID v1.11
Mouse [Microsoft Microsoft Basic Optical Mouse v2.0 ] on u0
[ 12.136047] udev: starting version 151
Remounting root file system...
[ 18.582336] mmcblk0: error -110 sending read/write command,
response 0x900, card status 0xe00
[ 18.596221] mmcblk0: error -110 transferring data, sector 7845368,
nr 8, card status 0xc00
[ 18.629333] end_request: I/O error, dev mmcblk0, sector 7845369
[ 23.916656] end_request: I/O error, dev mmcblk0, sector 7587529
[ 23.927978] end_request: I/O error, dev mmcblk0, sector 7587536
[ 23.939178] end_request: I/O error, dev mmcblk0, sector 7587544
[ 31.057586] EXT3-fs (mmcblk0p2): error: ext3_remount: Abort forced
by user
mount: you must specify the filesystem type
Caching udev devnodes
Populating dev cachetar: can't open '/etc/dev.tar': Read-only file
mv: overwrite '/etc/udev/saved.uname'? y
mv: cannot rename '/tmp/uname': Read-only file system
[ 33.591308] Bluetooth: Core ver 2.15

After loging in to the system as root, an error message displays
concerning read only files:

beagleboard login: root
root@beagleboard:~# /USR/SBIN/CRON: can't open log file
log: Read-only file system
/USR/SBIN/CRON: can't write to log file
root (04/19-17:30:00-989) CMD (/usr/bin/ntpdate -b -s -u
/USR/SBIN/CRON: can't open log file
log: Read-only file system
/USR/SBIN/CRON: can't write to log file
root (04/19-17:30:00-988) MAIL (mailed 61 bytes of output but got
status 0x0001

Hi Natxco -- I had reasonably good luck with the same process,
on my (plain old) Beagleboard. (viz., the files and procedures
from the Circuitco website.) The only difference was that I used
"Win32diskimager" to install the image onto the SD card. And
I'm on a regular BB, not BB-xM.

Win32diskimager registered a bogus complaint about the SD card,
but I simply dismissed it and continued.

Ahh... the other thing: The procedure from the Circuitco website
says to hold the USER button for 10 seconds -- I think it actually
needs to be held for longer than that, for this particular image.

I'm curious about SD cards being damaged from improper
insertion or removal. Is this problem prevalent?

/Rafe B.


You can power ON the board, but just before hold the User key and then without releasing it Power ON the board. And just after a 4-6 seconds press reset then see it will start booting.


Hi Dhananjay and Rafe

Thank you very much for your quick answers. Unfortunately the combinations you gave me (using the user button and then the reset one) didn’t work: i still get those error messages while the system boot.

I still can connect to the system after the booting, but what i’m trying is to have a “clean” boot, with no errors. I don’t know if it can be related to read/write permissions (even though i followed instructions and i copied and unpacked all the files/system with sudo root).

Thanks anyway for your time!