[bb xm rev. C with ubuntu 12.04] - Rootfs "corrupted" after first mount via NFS - no login prompt

Hi Guys,

after a first successful rootfs mount over NFS (where the system worked perfectly) and after the first reboot (done via sudo halt or sudo reboot commands), I can’t no longer login in to my bb xm. In fact, the login shell does not appear.

I suspect something in the rootfs get corrupted after the first reboot. If I delete this corrupted rootfs and substitute it with a new rootfs (with new I mean untarred from the original .tar and never mounted via nfs), then everything works as expected.

This is the relevant part of my /etc/exports file:


The rootfs I am using is called armel-rootfs-201207162218.tar and it’s contained inside the ubuntu-12.04-r4-minimal-armhf-2012-07-16.tar.xz archive. I obtained it from http://rcn-ee.net/deb/rootfs/precise/ubuntu-12.04-r4-minimal-armhf-2012-07-16.tar.xz

I untarred my rootfs with the command tar -xvf armel-rootfs-201207162218.tar (I tried also with sudo tar -xvf armel-rootfs-201207162218.tar to gain root privileges). No relevant differences noticed.

This is an excerpt from my boot messages (where login prompt doesn’t show up):

Ok, found the solution.

The problem was that the rootfs, once mounted, contained a /etc/network/interfaces file configured for dhcp. So the bb obtained the ip automatically at each boot, but this ip was different from the one I configured manually in uEnv.txt to tell the kernel to mount the rootfs via NFS.

So the 1) kernel used to boot up and 2) u-boot gave it a fixed ip address 3) with this ip the kernel mounted the rootfs 4) once mounted rootfs, the ip changed because of /etc/network/interfaces configuration.

In order to sove, I changed /etc/network/interfaces with the same fixed ip addr I gave to the kernel via u-boot. Then the rootfs mount didn’t break again.

Hope helps someone else!


It happend because you probably use * before the first bracket in the exports file, that means “all” hosts are allowed to mount this rootfs. No need to make limits sitting behind the NAT