[BBAI-64] edge ai gstreamer format pipeline

Hello, I am trying to run edge ai object detection with 640x480 resolution, please fix my command… :slight_smile:

dcc_viss.bin & dcc_2a.bin files on /opt/imaging/imx219

SDK version : imaging-REL.PSDK.JACINTO.09.00.00.02.zip

camera : rpi v2 csi camera
(possilbly checked with sudo /opt/edge_ai_apps/init_script.sh)

my command :

gst-launch-1.0 v4l2src2 device=/dev/video io-mode=5 ! queue leaky=2 ! video/x-bayer, width=1920, height=1080, format=rggb ! tiovxisp sensor-name=SENSOR_SONY_IMX219_RPI dcc-isp-file=/opt/imaging/imx219/dcc_viss.bin format-msb=7 sink_0::dcc-2a-file=/opt/imaging/imx219/dcc_2a.bin sink_0::device=/dev/v4l-subdev0 ! video/x-raw, format=NV12 ! tiovxmultiscaler name=split_01 src_0::roi-startx=0 src_0::roi-starty=0 src_0::roi-width=1920 src_0::roi-height=1080 target=0 split_01. ! queue ! video/x-raw, width=480, height=416 ! tiovxmultiscaler target=1 ! video/x-raw, width=416, height=416 ! tiovxdlpreproc model=/opt/model_zoo/ONR-OD-8120-yolov5-m6-ti-lite-coco-640x640 out-pool-size=4 ! application/x-tensor-tiovx ! tidlinferer target=1 model=/opt/model_zoo/ONR-OD-8120-yolov5-m6-ti-lite-coco-640x640 ! post_0.tensor split_01. ! queue ! video/x-raw, width=1280, height=720 ! post_0.sink tidlpostproc name=post_0 model=/opt/model_zoo/ONR-OD-8200-yolox-nano-lite-mmdet-coco-416x416 alpha=0.4 viz-threshold=0.6 top-N=5 display-model=true ! queue ! mosaic_0. tiovxmosaic name=mosaic_0 target=1 src::pool-size=4 sink_0::startx="<320>" sink_0::starty="<150>" sink_0::widths="<1280>" sink_0::heights="<720>" ! video/x-raw,format=NV12, width=1920, height=1080 ! v4l2h264enc extra-controls="controls, frame_level_rate_control_enable=1, video_bitrate=10000000, video_gop_size=30" ! h264parse ! matroskamux ! kmssink driver-name=tidss sync=true

result :

ERROR:../gst-libs/gst/tiovx/gsttiovxcontext.c:146:gst_tiovx_context_init: assertion failed: (0 == ret)
Bail out! ERROR:../gst-libs/gst/tiovx/gsttiovxcontext.c:146:gst_tiovx_context_init: assertion failed: (0 == ret)
Aborted