BBB A5A Wifi Dongle Locks Up after awhile

Ever since I received my BBB A5A, I’ve had trouble getting WiFi to work. Or rather I should say work consistently.

I am using an external power source rated at 5V, 1A through the barrel jack. I’ve also tried using a 5V 2.4A power source through the mini USB jack. I’ve tried Angstrom, and am currently running Debian 7.8

The behavior is that the board boots well, and from dmesg I see the following messages.

[ 11.690302] rtl8192cu 1-1:1.0: usb_probe_interface

[ 11.690327] rtl8192cu 1-1:1.0: usb_probe_interface - got id

[ 11.729916] rtl8192cu: Chip version 0x10

[ 12.339530] rtl8192cu: MAC address: 00:13:ef:71:14:7f

[ 12.339561] rtl8192cu: Board Type 0

[ 12.339681] rtlwifi: rx_max_size 15360, rx_urb_num 8, in_ep 1

[ 12.342293] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw.bin

[ 12.342701] usbcore: registered new interface driver rtl8192cu

[ 12.391585] ieee80211 phy0: Selected rate control algorithm ‘rtl_rc’

[ 12.393155] rtlwifi: wireless switch is on

[ 17.866425] rtl8192cu: MAC auto ON okay!

[ 17.946662] rtl8192cu: Tx queue select: 0x05

Everything runs perfectly for any where from a couple of hours to a day or so, then it locks up. Light on the WiFi USB dongle stops blinking, and all the lights on the BBB are static.

Has anyone had anything like this happen? Is this a known problem? I’ve tried several different USB WiFi dongles. I have multiple Raspberry Pi running, and I haven’t had this problem with them.

Does anyone have any suggestions on what to try?

Thanks.

Bruce

You might try an extension cable on the USB dongle or standoffs.

http://www.elinux.org/Beagleboard:BeagleBoneBlack#WIFI_Adapters

Gerald

Thanks, I’ll give it a try.

Bruce