BBB and I2C problem


I am working on a BBB project. I am looking to connect 3 devices to the I2C bus. I already have the DS1307 RTC model working. i2cdetect shows

60: – -- – -- – -- – -- 68 – -- – -- – -- –

I then connected the MCP23017 to the BBB, but cannot see the the address I set. I tried this with several different boards, that worked perfectly on a RasPi. I am really desperate to get a solution, but have no idea what I could do to fix the problem. This is what I did so far:

  • disconnect the RTC and kept another I2C device connected => 68 disappeared
  • changed the power supply from USB to external
  • used all the different power ports P9_03-P9_08
  • used the second I2C bus
    What else can I check. Is my BBB buggy?

I am running:
Debian GNU/Linux 7 (wheezy)

uname -a shows
Linux arm 3.8.13-bone28 #1 SMP Thu Sep 12 23:22:35 UTC 2013 armv7l GNU/Linux

Content of /etc/modules

No uncommented modules in /etc/modprobe.d/fbdev-blacklist.conf

Why is the RTC module working and all the other modules aren’t. Any advice would be really appreciated.

Thank you in advance.