BBB boots on SD card, not from emmc. Any ideas?

I’ve got a BBB (rev C) and I’ve been trying different images. As I was learning to flash it, I’ve gotten one of the boards in a state where it will boot off the microSD card, but not off the emmc. When there is no card inserted into the BBB, the power LED comes on steady, but there is no output on the serial terminal and none of the LEDs seem to work. However, when booting from a SD card, everything seems to more or less behave.

I haven’t booted on the SD card and tried to access the emmc, since I’m not entirely sure on how to do that.

I’ve attached the output of running a flasher SD card image that seems to complete normally. The SDcard seems fine; I’ve used it to flash another BBB just fine. The particular image on the SD card doesn’t seem to matter either.

There is one section of the output that seems suspicious, which I’ve copied from the attachment. It seems like the emmc partition table is somehow corrupted? I’m new to this though, so I’ll defer to anyone who knows more.

Thanks.

bbb_flasher_output.txt (26.3 KB)

I’ve put the flasher output on pastebin as well.

http://pastebin.com/U8g6UbbR

That looks fine.. sfdisk is just noisy that's all..

What is the serial output look like, after flashing, after removing
the microsd and after removing power.. (sysboot pins need to drain)

Then apply power..

What's the serial output at that point?

Regards,

I just tried again, and let the board sit without power for about 30 seconds. Plugging the power back in gives no serial output whatsoever.

I’ve tried holding the power, reset, and boot buttons in various combinations that I didn’t systematically document (but could, if needed), to no avail. The only thing that seems to matter is having the SD card in.

I gave this another shot, by loading a bootable (non-flashing) image on my sdcard.

The pastebin for the boot sequence off the serial port is: http://pastebin.com/12CGJRwG

The pastebin for dmesg with this image: http://pastebin.com/sAPCWDDy

The output of fdisk -l is here: http://pastebin.com/ge6aqPzn

Again, everything looks more or less fine. I can seem to access the emmc when booted with the sdCard. Without an SDcard inserted, only the power light comes up. Nothing else happens. No LEDs, no serial output.

One last thing. When powering down while booted onto the sdCard image by holding down the power button on the board, I get the following pastebin with a kernel panic in it: http://pastebin.com/GNcHTMcJ

[ 271.857528] (NULL device *): gadget not registered.
[ 271.873236] Power down.
[ 271.879350] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000

I don’t get this error when powering down a non-problem board that’s booted off either the same sdcard or the emmc.

Hello,

Try https://github.com/ungureanuvladvictor/BBBlfs to flash directly the eMMC.