BBB Ethernet stopped working.

Hi All,

I have a pair of BBB’s that I bought from Canada Robotix. They are both Rev C boards from Element 14. I’ve been running debian on a micro SD card on each of them. The one board had been running a web server for about 2 months straight, but suddenly lost Ethernet capabilities one day. Both the Ethernet LED’s stay ON solid even when no cable is plugged in. I tried to rule out software by loading up a couple different OS’s but none of them can connect to my network. I even tried flashing an experimental version of debian from the beagleboard.org wiki but that did not work either. When I boot into debian now I notice the ethernet lights blink for a bit then stop and stay on solid, and I get messages from dmesg like:

root@beaglebone:/var/lib/cloud9# dmesg | grep phy
[ 0.000000] Booting Linux on physical CPU 0x0
[ 2.715169] 47401300.usb-phy supply vcc not found, using dummy regulator
[ 2.830812] 47401b00.usb-phy supply vcc not found, using dummy regulator
[ 3.392979] davinci_mdio 4a101000.mdio: detected phy mask fffffffe
[ 3.399823] libphy: 4a101000.mdio: probed
[ 3.399859] davinci_mdio 4a101000.mdio: phy[0]: device 4a101000.mdio:00, driver SMSC LAN8710/LAN8720
[ 13.783697] net eth0: phy found : id is : 0x7c0f1
[ 13.783894] libphy: PHY 4a101000.mdio:01 not found
[ 13.788720] net eth0: phy 4a101000.mdio:01 not found on slave 1
[ 16.863473] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 46.943180] libphy: 4a101000.mdio:00 - Link is Down
[ 71.703444] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 79.783276] libphy: 4a101000.mdio:00 - Link is Down
[ 111.023649] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 233.103186] libphy: 4a101000.mdio:00 - Link is Down
[ 369.103554] libphy: 4a101000.mdio:00 - Link is Up - 100/Full
[ 385.183238] libphy: 4a101000.mdio:00 - Link is Down
etc… etc…

Does anyone have experience with this type of problem?
Other info:
root@beaglebone:/var/lib/cloud9# uname -a
Linux beaglebone 3.14.43-ti-r67 #1 SMP PREEMPT Thu Jun 4 20:37:18 UTC 2015 armv7l GNU/Linux

Everything else seems to work.

Thanks!

-John

.

If there is no way to resolve this issue does anyone know how to RMA an element 14 BBB?

Try GKirk@premierfarnell.com

Gerald

Hi Gerald, Thanks for the link. I’ve contacted Canada Robotix and have an RMA number now. If anything goes wrong with the RMA process I will let you know.

Other than this minor hickup I’ve been really happy with my Beaglebones (and Canada Robotix has been great so far). Any news on when a Rev D will be coming out? Or another product in the BBB line?

Thanks again!

-John

Next beagle has been talked about for months now.

http://elinux.org/Beagleboard:BeagleBoard-X15

Gerald

I was under the impression the BeagleBoards are a different family of products. Any news on a new BeagleBone in the works?

-John

Nothing planned. TI does not make another processor that fits the features of the AM3358 with any significant improvements. Any significant changes we made by adding features would not allow us to meet the price point we have now. No room at the price to add anything.

Gerald

Hi Gerald,

I saw your comment in response to the question about another revision to the BBB. There is a long standing issue with the BBB reset related to the Ethernet PHY not coming out of reset properly. In order to work around the problem you need to hack the board and drive the Ethernet PHY with a GPIO to ensure the proper reset timing for the PHY.

Is there any plan by CircuitCo to make a revision to address this issue? Its a rather tricky hack to do because you have to drill out one of the via’s to do it properly and that takes a special laser to do it.

Here is another link to a post on the TI forum that also discusses this issue and I have seen it discussed here as well. I am not aware of any software revision that has addressed this but perhaps there has been a software fix?

Phy Address Issue beaglebone U-boot - Sitara Processors Forum - Sitara™ Processors - TI E2E Community

Thank you,
Steve

You know, I’ve had my hand on 4 BBB’s and well over 40 BBG’s and have yet to see this problem manifest it’s self.

There is not a HW only fix for this issue. Period.

If you add a reset line to the PHY, you still need to override the pins on the processor to inputs for the reset to work. That is a SW change.

Just have the SW scan for one of the four addresses and use the one that is found. Simple fix that works.

Gerald