BBB Hangs during opkg upgrade

I’m running Angstrom-Cloud9-IDE-GNOME-eglibc-ipk-v2012.12-beaglebone-2013.08.21.img on a Kingston 16G sd card.

I can ssh into the BBB as root, created a new user, changed time zone, & etc. Seems to working okay… until I try to do the first big update!

Logged in as roon vi ssh, run opkg update, then upgrade. Opkg upgrade runs for a while, then appears to hang updating sulesautio from 2.1_r19.15 to .16.

Looking at the board, the power LED and only one User LED (2nd from the ethernet connector) is light. I have a green and a yellow LED on the ethernet connector and the green blinks every-so-often.


I ran into problems with big Angstrom updates also. In my case it was due to running out of RAM disk space since opkg uses temporary storage in RAM disk by default. By specifying temp space in an SD card directory I was able to work around this.
I don’t recall the exact command line switch but it was easy enough to figure out.


I read somewhere that opkg might fail because there is no swap space on Angstrom by default. I resized my linux partition to 15+ GB, and created a swap file. Seems to be working now, but I haven’t verified that the swapfile has been utilized yet.

Update completed. Top shows that 504K of swap space was used. Thus it appears that to do a opkg update/upgrade one must create a swap partition/file. This implies that a upgrade can only be done by booting off of a sd card.

That said… what was odd was that I did a successful update when I booted from the factory loaded os on EMMc! I wonder why that worked? :wink: