BBB + LCD7 cape + ubuntu + LXDE + virtual keyboard?

I have a BBB with a Ubuntu 14.04 distro on it.
I have the 4DSystems LCD cape.
I have LXDE wm on it.

This all works fine.

What I need is a virtual keyboard (preferrably one that pops up when I click an input box).
I have installed florence, but it apparently only works with GNOME.

I need something that works with LXDE.

Anyone got any ideas?


ok. I have SOLVED all of this.

I put this in the 4dsystems forum, and I repost it here.

The 4dsystems beaglebone cape with Ubuntu + LXDE is working just fine, and here is how I did it:

This is for ubuntu 14.04 and lxde, there is a utility named xinput_calibrator for x11

steps to make this work:

Note: I use the lxde window manager, so you might have to change this for your wm:

ssh into the beaglebone:

need to get a virtual keyboard up, and get past the login screen:

  1. as root, do an apt-get install xvkbd (so that you can run the terminal and use touchscreen for giving commands
  2. as root, edit /etc/lxdm/lxdm.conf:

uncomment and set autologin username to enable autologin

autologin=ubuntu (or whatever username you have made)

uncomment and set timeout to enable timeout autologin,

the value should >=5


  1. as the user (ubuntu, or other user edited as autologin= in the lxdm.conf file):

so in the $HOME/.config/lxsession/LXDE/autostart I added this: xvkbd -minimizable -no-keypad -geometry +150+150 &

the above gets the virtual xvkbd up on the screen (if not running with a keyboard, like me)

now: shutdown the bbb, and attach to the LCD cape, and boot up to the screen.
(1) the login screen should come up, wait for 5 seconds for the login to time out, then wait for lxde to start up
(2) you should see the screen come up with the virtual keyboard

now, start a terminal. hopefully it is an icon, if not, make it one and start again

once a terminal is up, focus to the terminal, then focus to the virtual keyboard

  1. sudo su -

now, as root do:

  1. apt-get install xinput-calibrator

  2. run xinput_calibrator and you will get something like the following:
    Section “InputClass”
    Identifier “calibration”
    MatchProduct “ti-tsc”
    Option “Calibration” “121 4028 303 3852”
    Option “SwapAxes” “0”

  3. edit the /etc/X11/xorg.conf file: and add that above section to it.

  4. shutdown and boot up again.

The screen should be calibrated correctly!

I hope this helps everyone. Whew!