BBB & MultiCast

I’ve tried to deactivate the Multicast with :

ifconfig eth0 -multicast

But when i check with this command, I can still see :

ip maddr show

2: eth0

link 33:33:00:00:00:01

link 01:00:5e:00:00:01

link 33:33:ff:9a:05:07


inet6 ff02::1:ff9a:507

inet6 ff02::1

Which is not good for me !

i’ve tried :

debian@beaglebone:/Distrib/Scripts$ sudo ip -r maddr delete dev eth0

ioctl: No such file or directory

I also tried to ping from an another device .

And with the command tcpdump I can see that I’m receiving multicast packet :

debian@beaglebone:/Distrib/Scripts$ sudo tcpdump -p -i eth0 host -n

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode

listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes

16:09:28.679257 IP > ICMP echo request, id 1, seq 1913, length 40

Why ? I really don’t know what to do about it, My idea is to deactivate multicast in the kernel build config … Does it sounds good for you ?

Thank you,


First google result seems useful:

Well …

I know google too, and I know this link . Thx for the answer .

My problem is that the beagle still receive the multicast packet (yes it ignore all multicast packet), which is a problem for me when you are in a network full of camera That love to send multicast packet !

I tried to disable multicast in the kernel, but it still receive multicast packet. Do you know a solution to prevent this ?


debian@beaglebone:/Distrib/Scripts$ sudo tcpdump -p -i eth0 host -n

What does the -p do?

From tcpdump man page:

*Don't* put the interface into promiscuous mode. Note that the interface might be in promiscuous mode for some other reason; hence, `-p' cannot be used as an abbreviation for `ether host {local-hw-addr} or ether broadcast'.