BBB no hdmi display

Hi all,

I am a novice on beaglebone black. I purchased new BBB. But I do not get any display. I tried connecting to LG 22LH20R TV (1366X766p) and HP monitor (1366x768p). On connection, it shows only “problem with HDMI cable. Please check connection”.

Below is the log book of the processes I tried:


  1. Connect the serial cable to your PC.
  2. Launch the terminal emulation SW and select the correct serial port.
  3. Connect the serial cable to the serial debug connector on the board.
  4. Connect the HDMI cable to the board and your display.
  5. Apply power to the board.
  6. You should see messages appear on the terminal.
  7. When the login prompt appears type root and hit enter.
  8. Type export XAUTHORITY=ls /var/run/gdm/auth-for-root-*/database and hit enter.
  9. Type export DISPLAY=:0.0 and hit enter.
  10. Type xrandr --output HDMI-0 --mode 720x480 --rate 60. You can substitute different resolutions and refresh rates if you like. Hit enter.
    The resolution should change on the display. If you get the message “xrandr: cannot find mode 1920x1080” where the 1920x1080 in this example is the mode you selected, that means that the DRM driver did not select it as an available resolution.

root@beaglebone:~# lightdm -d
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.2.2, UID=0 PID=1214
[+0.01s] DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
[+0.01s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.02s] DEBUG: Using Xephyr for X servers
[+0.02s] DEBUG: Registered seat module xlocal
[+0.02s] DEBUG: Registered seat module xremote
[+0.03s] DEBUG: Adding default seat
[+0.03s] DEBUG: Starting seat
[+0.03s] DEBUG: Starting new display for automatic login as user debian
[+0.04s] DEBUG: Starting local X display
[+0.06s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.06s] DEBUG: Using VT 7
[+0.07s] DEBUG: Activating VT 7
[+0.07s] WARNING: Error using VT_ACTIVATE 7 on /dev/console: Inappropriate ioctl for device
[+0.07s] WARNING: Error using VT_WAITACTIVE 7 on /dev/console: Inappropriate ioctl for device
[+0.08s] DEBUG: Logging to /var/log/lightdm/x-1.log
[+0.08s] DEBUG: Can’t launch X server Xephyr, not found in path
[+0.09s] DEBUG: X server stopped
[+0.09s] DEBUG: Releasing VT 7
[+0.09s] DEBUG: Display server stopped
[+0.09s] DEBUG: Stopping display
[+0.10s] DEBUG: Display stopped
[+0.10s] DEBUG: Stopping X local seat, failed to start a display
[+0.10s] DEBUG: Stopping seat
[+0.11s] DEBUG: Seat stopped
[+0.13s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
Failed to use bus name org.freedesktop.DisplayManager, do you have appropriate permissions?

sudo -i
echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
update-initramfs -u
sudo reboot

$cvt 1366 768
Modeline “1368x768_60.00” 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
$xrandr --newmode “1366x768” 85.25 1368 1440 1576 1784 768 771 781 798 -Hsync +Vsync
$xrandr --addmode VGA1 “1366x768”
$xrandr --output VGA1 --mode “1366x768”

xrandr -display :0.0 -q
xrandr -display :0.0 --output HDMI-0 --mode 1024x768 --rate 60

Can someone please help me out here?