BBB re-flash

Hello all,

I was working with my BBB the other day and I was trying to get an OS other than Angstrom on it and I accidentally wrote the ubuntu img over the 73mb partition that shows up with BBB is plugged in. I have gathered that this is the boot partition and it seems right because when I try to boot it without an SD card the user lights never come on.

So I DDed the angstrom re flash image to an SD card to attempt to fix it but all four lights never come on to signify the re flash process is done and I’ve done this several times giving it a couple hours a try. Right now as I stare at it the left light does a double flash once per second and the third one flashes a bunch kinda sporadically. I read somewhere that you can’t plug ANYTHING into it or else it will just boot up which i hope isn’t true because all I have to power it is a USB cable and I tried a cell phone charger with it to no avail.

When I fdisk -l the 73MB partition does come up but has zero partitions. Does the reflash image not restore this? How do I restore this if not?

Lastly the very beginning of this was I was trying to install TTYLinux. Is there a tutorial for installing TTYLinux to BBB? I tried simply extracting the contents of the tar to my SD card but that didn’t seem to work. Not sure what other variables might have been mucking up that test at that point though.

Well I got it to go finally by:
using gparted to format the 73mb boot partition as FAT
rewriting the flasher SD card

Still no luck with TTYLinux though

hi could you elaborate this a bit more ?

I had the problem at testing, the system refused to start
and i tried to flash it via SD-card.
The card itself booted fine but i was unable to flash.


Well I can explain this in linux but not so much in windows, haven’t used it in years.
So with the BBB plugged in via USB fdisk -l should have a 73MB~ device on this list. From what I gather this needs to be a FAT partition, I did this with gparted personally. This may not be true but since it worked once I will do as the crow does. Then you boot off the sdcard with nothing but USB or a power adapter plugged in. If you can SSH into the system then something has gone wrong and the system has booted instead of gone into flashing. For me it finished somewhere during my second episode of TV I was watching.