BBB RevC will not boot from usb or eMMC

Hello, first time poster in here.
I have a BeagleBoard Black RevC, that boot up at one time.
Following Beagleboard:BeagleBoneBlack Debian -
I tried to “Flash eMMC” so I could boot without needing the SD card. However, I believe I was trying to use a non-flash eMMC type image. And ever since that, I cannot get the board to bring up any sort of way to connect to it. I have tried removing the SD card, pressing and holding the “S2 User” button and powering the board (via usb) then releasing the button after I see the led above the USB power power port all light up. But it seems to be stuck in flash mode. I have tried reformatting the SD card, and applying several different images, then inserting the SD card, and pressing the “S2 User” button until the leds light up. The board appears to start the install (the leds bounce back and forth), then all 4 leds come on solid. I have left the board in that state for 2 hours at the longest period to no avail.

I am hoping someone can help me get the board back to a bootable state…

PLEASE and thank you in advance.

Do you have a usb-serial adapter so we can see what’s happening over J1? ( Beagleboard:BeagleBone Black Serial - )…

Otherwise use with the latest snapshot, Debian 11.x (Bullseye) - Monthly Snapshots and it use it too bootup with the mciroSD.


Thanks for the response. I have been using etcher and have tried several images now…
Your suggestion being the latest…
The process,
Format the 32GB SD with default properties
Download BBB image
Open “BalenaEtcher” and flash the image to the SD card (by the way verify always fails)
Insert Sd into BBB RevC SD slot
Hold the S2 button down (I get the same results below without holding S2 down as well)
Plug in the USB Power
Continue to hold the SE button down until all 4 LEDs light up
Release the S2 button
The d2 0, d3 1, d4 2, d5 3 LEDs just about the USB power port flash randomly then do
the LED bounce (where they light up from left to right, the right to left) and go back and forth
like that for a couple minutes, then either d3 1, or d4 2 will light up by its self, and a few seconds
later, all 4 leds come on solid, and they will stay that way no matter how long I leave it.

Hope this helps

That’s a flashing sequence… cylon pattern…

On success the board will shut, on failure all LEDs will blink together as one…

Really really old images would not properly shutdown. Which image are you trying to flash to the emmc?


One thing I have noticed, is in a windows command prompt I am not seeing the IP addresses or associated with USB when doing an ipconfig /all which I did see during my initial executions where I could access both the cloud9 interface, and the FPP web interface.

I have tried the following :

  • bone-debian-10.13-lxqt-armhf-2022-11-01-4gb.img.xz
  • bone-debian-10.3-console-armhf-2020-04-06-1gb.img.xz
  • am335x-debian-11.5-minimal-armhf-2022-11-01-2gb.img.xz

And after trying using rufus vs. etcher, with am335x-debian-11.5-minimal-armhf-2022-11-01-2gb.img.xz
the process went through the same LED sequences, however, instead of all 4 LEDs being on solid, D3 1
is the only LED that is on solid

I must say , I have not seen "all LES blink together as one: during all the attempts…

Thanks again

Well it’s definitely booting into something… If you can’t ssh in over Ethernet or USB, you best option is to plug a usb-serial adapter into J1 and find out what it’s doing…


Thanks Robert. There appears to be several options in that link you provided yesterday.
Can you point me to the correct one to use with my BeagleBoard Black RevC please? I
will get it ordered and can hopefully get it shipped quickly…

The Standard 3v3 FTDI has an easy connector, just match the GND pin, but they usually run $20/$25 as they are FTDI so you pay the namebrand tax. The other units usually run a 1/3 to 1/2 price, but you need to lookup the pin colors and figure out GND, TX, and RX.

So it’s up to you…


Do you know if all the leds lit up solid after an attempted boot up, indicate any sort of status?

There’s a sequence in u-boot, where the lights are turned on sequence… 1, 2, 3, then 4… Right before jumping to the linux kernel and booting up.

It’s really not useful for debugging fail to boot…

Then once linux takes over, they become…

  • heartbeat
  • mmc0
  • cpu0
  • mmc1


1 Like

And I now have the cable in hand

The cable should be here today some time. I did order the Standard 3v3 FTDI that has the
“easy connector”

Can you provide me some steps I need to take once I have the cable?


The Dot next to J1 is GND, on your FTDI cable, the black wire is GND… Plug those in…

Then in Linux, fire up gtkterm or cutecom…

115200 8 n 1

More pictures (PocketBeagle):

PocketBeagle has a different pinout, whereas teh BBB can be plugged in directly…


sorry, meant to add the log for “WITH” SD, and with “OUT” sd
puttysessionWITH-SD.txt (10.0 KB)

got the output of both a boot up with, and without the SD card inserted
puttysessionwithOUT-SD.txt (4.1 KB)
puttysessionwithOUT-SD.txt (4.1 KB)

Ahh, that looks fun!!

At some point you had a corrupted microSD, which flashed the eMMC with a corrupted image, and now on every bootup, the eMMC is trying to flash the microSD…

Remove all media, using the terminal program, hold the space bar down (space is the only magic key to stop u-boot), turn on power…

Then in u-boot run these two commands…

=> mmc dev 1
=> mmc erase 0 100000

That should blank out the eMMC, and now you’ll only get “CCCCCCCC’s” from serial?

Finally, grab a new latest-image:


1 Like

executed the erase.

Are you saying during a reset, or a power cyclem?

Also , I just got back from BestBuy, bought 4 NEW 32gb V10 SD cards. :wink:

Oh after a reset…(or power cycle)… You should only get CCCC, which will tell us everything is blank and ready for the next state…


1 Like


So I am assuming I can go back and start with “Getting Started” again???

This is the image I downloaded

Should I try a non-eMMC flasher image, like my FPP imgage first?