BBB unstable connectivity with OSx Yosemite


I’m running on Yosemite 10.10.2.
I used mini-usb cable to connect BBB to my mac and it appears as a storage device.

I followed the instructions in START.htm; installed FTDI and HoRNDIS drivers.
The first time I did that, everything worked just fine. SSH was successful, hadn’t tried internet connection because of network security.

After a while, I disconnected the cable and plugged it in again.
The drivers seemed not to be loaded properly. So I install them over and over.
Also tried other versions of FTDI and HoRNDIS.
Sometimes it works, but most of the time it doesn’t.

I checked in my network connection and found an entry of BeagleBoneBlack.
The status is:
“Not Connected”.
“The cable for BeagleBoneBlack is connected, but your computer does not have an IP address.”
Automatic DHCP is set.

So, I can no longer try SSH and check any other settings on BBB.

Any advice will be appreciated.


The FTDI drivers aren’t compatible with Yosemite due to the requirement to sign the drivers. I tried to update these at to a version that is signed. Of course, you don’t need the FDTI drivers for the ssh.

For the Ethernet, you might make sure you have version 6 of HoRNDIS. Depends how long ago your board was flashed, but the latest is on that same getting-started page I just shared and at

I’ve seen times when I needed to go manually add the adapter (shows up when you hit the + to add a network device), but if the cable detection is there, that isn’t likely the issue.

You should still be able to log into your board via the command-line and ‘screen’. Use something like ‘screen /dev/tty.usbmodemfd113 115200’. I don’t know how OSX determines the numbers. I just try one until it is the right one. It’ll immediately come back with a screen like:

Debian GNU/Linux 7 beaglebone ttyGS0 Debian Image 2015-01-19


default username:password is [debian:temppwd]

The IP Address for usb0 is:

beaglebone login:

Once you are there, you can login as ‘root’ (no password) and collect a ‘dmesg’ log that might be somewhat informative.

The server responsible for giving an IP address to your Mac is called ‘udhcpd’. I made sure my was running:

Thanks for information about FTDI and all suggestions.
I had tried several versions of HoRNDIS but I’ll focus more on version 6.

I also used screen command once while ssh was working and it probably worked like how it should.
I would try fetching dmesg once I get back to the device. Hopefully it’s gonna work.

Thanks again and Best,

Getting back with an information from dmesg.
First - third time I tried plugging the USB cable, it seemed to be working correctly.

At the fourth time, my mac saw the cable was connected. But it didn’t recognize BBB as a network connection (sad to say that I was happy I could reproduce the error)
Here’s what dmesg gave

[ 39.221501] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.221514] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.221700] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.231173] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.231207] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.231228] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.231460] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.231493] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.231507] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.231521] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.231703] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.249515] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.249551] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.249571] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.249808] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.249843] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.249857] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.249871] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.250051] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.255049] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.255081] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.255099] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.255325] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.255352] [drm:drm_ioctl], pid=236, cmd=0xc05064a7, nr=0xa7, dev 0xe200, auth=1
[ 39.255367] [drm:drm_mode_getconnector], [CONNECTOR:5:?]
[ 39.255380] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1]
[ 39.255556] [drm:drm_helper_probe_single_connector_modes], [CONNECTOR:5:HDMI-A-1] disconnected
[ 39.495844] fuse init (API version 7.20)
[ 40.844350] [drm:output_poll_execute], [CONNECTOR:5:HDMI-A-1] status updated from 2 to 2
[ 50.875553] [drm:output_poll_execute], [CONNECTOR:5:HDMI-A-1] status updated from 2 to 2
[ 53.296404] gadget: acm ttyGS0 req21.22 v0002 i0002 l0
[ 53.296462] gadget: acm ttyGS0 req21.22 v0003 i0002 l0
[ 53.296508] gadget: acm ttyGS0 req21.20 v0000 i0002 l7
[ 53.296568] gadget: acm ttyGS0 req21.20 v0000 i0002 l7
[ 53.308521] gadget: acm ttyGS0 serial state 0003
[ 60.906808] [drm:output_poll_execute], [CONNECTOR:5:HDMI-A-1] status updated from 2 to 2
[ 70.938066] [drm:output_poll_execute], [CONNECTOR:5:HDMI-A-1] status updated from 2 to 2

and here’s about udhcpd

root@beaglebone:~# ps auwx | grep udhcp
root 224 0.0 0.1 2152 676 ? S 00:00 0:00 /usr/sbin/udhcpd -f -S /etc/udhcpd.conf
root 603 0.0 0.1 1960 612 ttyGS0 S+ 00:02 0:00 grep udhcp

It makes quite too little sense to me to understand what’s going on. I hope you could help me figure it out.
Thank you and appreciate your time,