BBB USB Feature being blocked from my Laptop

Hello, I just received my BBB for the first time and I have been having trouble with the USB storage on it. I downloaded the drivers (64 bit version) for my laptop, passed the security warnings and it gave me the “ready” status to connect it to my laptop. Once plugged in the BBB boots up just fine, but when I go to My Computer, it doesn’t show up, even after a long time. In the Device Manager, its labeled in the Other Devices category and it has the yellow exclamation triangle. I reinstalled the drivers a number of times and its been giving the same result. I tried it on a friend’s laptop and it was working. Now, I don’t understand as to how come when installing the drivers, my Windows states them as unsigned drivers and just blocks them from accessing it. I wasn’t sure if it was related to my antiviruses which were blocking it but uninstalling them or turning them off didn’t make a difference. I reflashed the eMMC to give it a try but still no luck. I tested on my TV and it worked fine. I unmounted and mounted the BEAGLEBONE from the BBB hoping that it would make a difference but no use.

My main question is how come my laptop is prohibiting the BBB when it works on another? I can’t just go to my friend’s laptop and finish my work on it. Are there any other drivers or an updated version of the drivers needed? Is there an option in Windows that can be changed to allow the drivers to work on the BBB?

Hi Zain,

wich windows are you use?

did you install (

when i have those problems i delete the yellow marked drive or click on update drive and let windows try to install it. some times i look up on the driver directory to force windows install it.

Yeah my version of Windows is Windows 7 Ultimate (64 bit Edition). I just got the problem solved today and now the BBB works! What I did to fix it was actually something I previously attempted but i think it didn’t work properly. I reflashed the eMMC again for the 3rd time and then plugged it in and the drivers started installing properly. I was surprised to notice it was the reflashing that fixed it when i tried it the 1st and 2nd time on it. Thanks for the advice on forcing Windows installing it. I will keep it in mind incase this problem happens on another computer.