BBB won't finish flashing the eMMC

I have tried flashing the eMMC on my BBB with both the latest Debian image as well as the latest Angstrom image found under the getting started tab of the beaglebone website.

I put the image into the micro SD card slot in the BBB and held the boot button until the four status lights all turned on for a few seconds. After this, the heartbeat pattern is running on the board and the D4 LED is dimly lit. I have watched some videos that show this happening after the boot button has been pressed down, however no matter how long I wait for the LED’s never go solid to notify me the flashing is done. I also bought the board from Element14.

I left the board powered on for a night and awoke to it still doing the same heartbeat pattern with D4 dimly lit, so I tried powering it off and seeing what I could find when connecting to it via USB. It did not create the web server or anything so I am fairly sure it didn’t update teh eMMC.

Any suggestions would be appreciated.

What was the name of the file?


more important is that you power it from a 2 amp power supply and not
the USB