BBBW Indicator LEDs Not Working?


The BBBW I’m using will freeze up randomly throughout the day, and I can’t SSH into it and Node-Red definitely stops running. I’m trying to flash it but the indicator LEDs do not light up when I hold the boot button down when applying power. Also when I booted normally before, the PWR WL and BT lights came on but none of the USB0-USB3 lights.

I can’t seem to flash a new version of debian now. Is this board dead?

This is a bug in u-boot that i forgot about till recently… U-Boot v2021.10 I use in Bullseye has a broken gpio command so led changes do NOT occurs in boot-up , vs v2019.04 in older release’s…


This is what happens when I plug it in with an SD card inserted with a flasher image new or old versions, the USR lights turn on but only for a second. And then the PWR and BT lights stay on indefinitely, but the board is inaccessible.
When I hold the S2 button while I plug in power, only the PWR light comes on.

Any thoughts on how I can get the board to boot? Plugging in via USB, I do not see the board as a removable drive. Booting from SD doesn’t seem to work either. Should I try an older version of debian?

it really looks like it’s booting, (what image did you try)… Do you have an adapter to plug into J1? Beagleboard:BeagleBone Black Serial - then we can see what’s really going on…


@RobertCNelson Thank you for responding so quickly and your help!

I have tried the following versions:

  • AM3358 Debian 10.3 2020-04-06 4GB SD IoT
  • AM3358 Debian 10.3 2020-04-06 4GB eMMC IoT Flasher
  • Debian 9.9 2019-08-03 4GB SD IoT
  • Debian 9.5 2018-10-07 4GB SD IoT

I don’t have an adapter, can I get one from Micro Center? Or can I make one from a regular USB cable?

please try this image:


From: here Debian 10.x (Buster) - Monthly Snapshots

Use etcher, to flash the microSD: balenaEtcher - Flash OS images to SD cards & USB drives

Remember to insert the microSD, hold the boot button, insert power, lift off finger when first led turns on…


No USR LED turned on after holding the boot button for five minutes. I used a new SD card, and have been using balenaEtcher every time. I tried the version you recommended, and followed the steps again of inserting, holding, applying power, and continuing to hold the boot button. I have a new BBBW coming tomorrow, I will try the steps with that one.

Just before that error I got this:

This is a new BBBW, but I must be messing up the flashing process because I’m getting an error:

Awesome!! your set the “flashing” flag on the file system of the eMMC!!!

So now your on a loop, where on every bootup, the eMMC loads and tries to copy itself to the microSD!

Give me a second, the easy fix is nuke the eMMC from u-boot prompt… it’s been awhile…


Oh great! What do you think happened that might have caused this?

Someone edited the file on the wrong partition… it’s easy to fix, so not a big problem…

First I’ve got U-Boot tuned to boot pretty quick, the space bar is the only key it’ll recognize to stop auto boot up…

So fire up your favorite serial terminal, remove the microsd, hold the space bar and plug in power…

You should see:

U-Boot SPL 2019.04-g923f8b8 (Jan 02 2022 - 19:05:15 +0000)
Trying to boot from MMC2
Loading Environment from EXT4... Card did not respond to voltage select!

U-Boot 2019.04-g923f8b8 (Jan 02 2022 - 19:05:15 +0000)

CPU  : AM335X-GP rev 2.1
I2C:   ready
DRAM:  512 MiB
No match for driver 'omap_hsmmc'
No match for driver 'omap_hsmmc'
Some drivers were not found
Reset Source: Power-on reset has occurred.
RTC 32KCLK Source: External.
Loading Environment from EXT4... Card did not respond to voltage select!
Board: BeagleBone Black
<ethaddr> not set. Validating first E-fuse MAC
BeagleBone Black:
Model: BeagleBone Black Industrial:
BeagleBone Cape EEPROM: no EEPROM at address: 0x54
BeagleBone Cape EEPROM: no EEPROM at address: 0x55
BeagleBone Cape EEPROM: no EEPROM at address: 0x56
BeagleBone Cape EEPROM: no EEPROM at address: 0x57
Net:   eth0: MII MODE
cpsw, usb_ether
Press SPACE to abort autoboot in 0 seconds

if it get’s passed that stage… Just remove power and try again… The SPACE bar is the only key that’ll stop autoboot…

In u-boot, by default mmc 0 → microSD, verify by, typing mmc dev 0 and then mmc info…

=> mmc dev 0
Card did not respond to voltage select!
=> mmc info 
Card did not respond to voltage select!

You want to see that ^… Then we know you don’t have the microSD plugged in, so switch to eMMC via: mmc dev 1…

=> mmc dev 1
switch to partitions #0, OK
mmc1(part 0) is current device

now run mmc info and we should see a printout of your eMMC:

=> mmc info
Manufacturer ID: 70
OEM: 100
Name: M6270 
Bus Speed: 48000000
Mode : MMC High Speed (52MHz)
Rd Block Len: 512
MMC version 5.1
High Capacity: Yes
Capacity: 3.6 GiB
Bus Width: 4-bit
Erase Group Size: 512 KiB
HC WP Group Size: 4 MiB
User Capacity: 3.6 GiB
Boot Capacity: 2 MiB ENH
RPMB Capacity: 512 KiB ENH

Now we can erase it, so starting from block 0, let’s erase the first 0x100000 blocks, should erase most of the bootloader…

=> mmc erase 0 100000

MMC erase: dev # 1, block # 0, count 1048576 ... 1048576 blocks erased: OK

Next let’s verify the bootloader got zeroed out… just type reset and you should only see a repeated C’s…

=> reset
resetting ...

At this point, u-boot on the eMMC has been erased… Now any microSD should boot fine. :wink:


1 Like