BBxM not booting; D5 and D14 lit

Hello,

I’m working with a BBxM Rev C running Angstrom Linux.
This board has been working great for months, with no previous issues.
After a normal power down and power up, the board has stopped responding and does not output any information to the serial port.
LEDs D5 and D14 are constantly on when powered up. D13 flashes briefly, like normal, when power is applied.

There are no visible shorts.
I have tried using the RESET and USER buttons, verified that my serial cable is okay, and tried different sD cards.
I have also tried two different +5V, 3A power wall converters to power the boards.
I’ve even tried powering up without an sD card in hopes to see some sort of message in the putty terminal. No luck.

The software I was running used I2C-2 and I2C-3, the camera port, and two GPIO pins on the expansion header. It also used D6, D7, and the USER button.

Does anyone know if this can be fixed?

Thank you in advance,

  • C

I would try an recreate the SD card. Sounds like it may have gone bad or was corrupted during a power down.

Gerald

Gerald,

Thank you for the prompt reply!
I have tried booting it with the original sD card that came with it, with no response. I have also tried this same sD card on another BBxM that I bought (so I can continue developing) and it works fine - with all the normal bootup scripting.

Sounds like something happened to the board then. Your best bet may be to send it in.

http://beagleboard.org/support/rma

Gerald

Thanks for the support!
Have a nice rest of the day.