[beable board] USB issue with AIRLINK101 ethernet adapter while copying files over NFS

Hi all,

I am using USB to ethernet adapter from AIRLINK101. I am connecting it
to beagle board using 4 port USB HUB. I am able to configure the
ethernet interface and mount NFS.
When I try to copy big size files (>30MB) from NFS to USB pendrive or
MMC and vice-versa, I am getting following messages,

<5>nfs: server 192.168.10.10 not responding, still trying
nfs: server 192.168.10.10 not responding, still trying
<5>nfs: server 192.168.10.10 OK
nfs: server 192.168.10.10 OK

Sometimes, even with these messages file copy is done completely, but
takes long time. Some times file copy doesn't complete. For smaller
size files (<1MB), file copy happens correctly without those
messages.

Does anybody know the reason for these messages? How can I solve it?
Has anybody faced similar issue?

Regards
Satyajit

This should probably be in the FAQ. It's a known bug in the current
MUSB code. Here is another recent bug where fixes were discussed:

http://groups.google.com/group/beagleboard/browse_thread/thread/2ad517c215a6dabe/3f5b7acb20e52f94#3f5b7acb20e52f94

Unless you are already building your own kernels, I suggest you use
Koen's prebuilt kernels, since he has fixed a number of other bugs.

- Nathan

Thank you Nathan for you prompt reply.

Here is another recent bug where fixes were discussed:
http://groups.google.com/group/beagleboard/browse_thread/thread/2ad517c215a6dabe/3f5b7acb20e52f94#3f5b7acb20e52f94

I have applied the patch mentioned in above link and also followed other instructions in the post.
But still I get those NFS issues. I will try with Koen’s prebuilt kernels, and get back to you.

Thanks and regards
Satyajit K.

Hi Nathan,

I tried using Koen’s prebuilt uImage at
http://www.angstrom-distribution.org/demo/beagleboard/uImage

First thing, it crashes with USB PENDRIVE and ETH adapter working simulatneously.
Second, when I tried to use ETH adapter alone, NFS messages still comes up. This is not fixed in this image.

I couldn’t able to find, these NFS related threads in FAQ.
If any of you have any pointers regarding this, please let me know.

Regards
Satyajit

Hi,
One more thing,
Where can I get source code for Koen’s kernel (2.6.26).

Regards
Satyajit

Hi Nathan,

I tried using Koen's prebuilt uImage athttp://www.angstrom-distribution.org/demo/beagleboard/uImage

First thing, it crashes with USB PENDRIVE and ETH adapter working
simulatneously.
Second, when I tried to use ETH adapter alone, NFS messages still comes up.
This is not fixed in this image.

I think Nathan meant:
http://dominion.thruhere.net/koen/OE/uImage-2.6.26+2.6.27-rc7+r14+gite1c49d7d22af768188e2a54c167ed79919361e55-r14-beagleboard.bin

Hi,
One more thing,
Where can I get source code for Koen's kernel (2.6.26).

As said before: all kernel patches are in OpenEmbedded

Thank you Koen for your suggestions.
I tried uImages present at
http://dominion.thruhere.net/koen/OE/uImage-2.6.26+2.6.27-rc7+r14+gite1c49d7d22af768188e2a54c167ed79919361e55-r14-beagleboard.bin

But still I get those NFS messages for long file copy. Does anybody know fix for this??

Regards
Satyajit