Beagle Black no boot holding S2

I’m trying to flash the latest Debian image to a B6 revision board but if I hold S2 it prevents boot up, power light remains on and None of the 4 LEDS light. It boots fine without holding S2 but does not boot from the SD.

The SD is formatted correctly and I can flash other Beagle Black Wireless boards from it.

Please help I can’t see this problem anywhere on the web.

1 Like

Hello… versioning B6 has the eMMC at 2GB, I think. The latest Debian images from this forum,, or all have images larger than 2GB (I think).

Anyway, have you tried the reset button yet? Maybe booting from SD Card is what it is supposed to do.

It should boot from SD Card by itself if you are using one of the newer images.


P.S. I could be wrong but I will continue to try to help. oh!

Here is something that may help: Debian 11.x (Bullseye) - Monthly Snapshots

Those are the newer images that are testing images for the BBB.

Thanks so much I never would have realised this.

So I now have the problem that means I also can’t boot from an SD-card. I’m using an slightly older 9.9 Debian image that comes with a GUI that doesn’t auto boot from the card.
I tried it on a Wireless BB holding S2 and the SD is booting working fine.

Do you have a serial cable that you can connect into J1, so we can see what’s going on?