Beagle Board Black does not boot when powered from 5V barrel ...


thank you for sharing your experience. I think I will give a try to your proposed solution.



Looking up the part number, it says 2.5MM. which is too big. Holding the power button down I suspect is causing the cable to flex and make a mechanical connection and not anything to do with the button itself.

The correct part number is


OK, so I performed several tests this afternoon.

First of all, I tried to make the connector a litlle bit wider (withtout any shortcut) but the behaviour remained the same.

After that, I tried powering the board with another power supply (coming from a custom board 24 to 5V DC/DC converter) and performed several tests with a switch: all power on sequences resulted in an immediate successful boot. This is fine as this configuration could fit my demonstration.

Finally, just to be sure about the initial power supply connector I was using, I just got rid of the connector by bypassing it (using soldered wires going to DGND (P9, pin1) and VDD_5V (P9, pin 5).
The behaviour was exactly the same as described in my initial post. On the Farnell web site, the incomplete DA12-050MP-M as underlined by Gerald thus seems to be 2.1mm output plus as it is specified on the description page.

So, for the moment, the conclusions I am considering are:

  • the connector of the power supply is not faulty (as I got the same results without it)
  • the power supply I was initially using is (for some unknown reasons) not compatible with the BBBlk board (as with an alternate power source everything is fine)
    (–> I have to signal this to Farnell as they are higlighting this one as the right accessory)

The only question which remains is how pushing the POWER button can make the board boot … sometimes.

Anyway, thank you very much to everybody for your help.
This is really pleasant to have such experience sharing.



If the supply is slow to ramp, the soldering it in would result in what you are seeing.